configure.ac: link CoreServices only on MacOSX

CoreServices is an iOS 12.0+ API so it cannot be linked when targetting
iOS 9.0. However it is still needed for MacOS and available since 10.0+
which is lesser than the target version.

See https://developer.apple.com/documentation/coreservices
13 jobs for !2 with ios/armv7-ci/1 in 35 minutes and 47 seconds (queued for 2 seconds)
merge request