Commit dc0e019b authored by Rafaël Carré's avatar Rafaël Carré

drop v4l2 patch

parent 27a76b48
From 8d8a6189c5c53b6c8186adda2945dc9bb017afb6 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Kempf <jb@videolan.org>
Date: Thu, 22 Sep 2011 18:14:31 +0200
Subject: [PATCH 7/7] configure: allow a --disable-v4l2
This is needed because some distro have broken headers
---
configure.ac | 32 ++++++++++++++++++--------------
1 files changed, 18 insertions(+), 14 deletions(-)
diff --git a/configure.ac b/configure.ac
index 90de262..8fa1531 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1901,26 +1901,30 @@ fi
dnl
dnl Video4Linux 2
dnl
+AC_ARG_ENABLE(v4l2, [AS_HELP_STRING([--enable-v4l2],
+ [support V4L2 cards (default enabled)])])
AC_ARG_ENABLE(libv4l2, [AS_HELP_STRING([--disable-libv4l2],
[disable userspace V4L2 library (default auto)])])
AC_ARG_ENABLE(pvr, [AS_HELP_STRING([--enable-pvr],
[support PVR V4L2 cards (default disabled)])])
have_v4l2="no"
-AC_CHECK_HEADERS([linux/videodev2.h sys/videoio.h], [
- have_v4l2="yes"
-])
-AS_IF([test "$have_v4l2" = "yes"], [
- AS_IF([test "${enable_libv4l2}" != "no"], [
- PKG_CHECK_MODULES(LIBV4L2, libv4l2, [
- AC_DEFINE(HAVE_LIBV4L2, 1, [Define to 1 if libv4l2 is available])
- ], [
- AC_MSG_WARN([${LIBV4L2_PKG_ERRORS}.])
+if test "${enable_v4l2}" != "no" ; then
+ AC_CHECK_HEADERS([linux/videodev2.h sys/videoio.h], [
+ have_v4l2="yes"
])
- ])
- AS_IF([test "${enable_pvr}" = "yes"], [
- VLC_ADD_PLUGIN([pvr])
- ])
-])
+ AS_IF([test "$have_v4l2" = "yes"], [
+ AS_IF([test "${enable_libv4l2}" != "no"], [
+ PKG_CHECK_MODULES(LIBV4L2, libv4l2, [
+ AC_DEFINE(HAVE_LIBV4L2, 1, [Define to 1 if libv4l2 is available])
+ ], [
+ AC_MSG_WARN([${LIBV4L2_PKG_ERRORS}.])
+ ])
+ ])
+ AS_IF([test "${enable_pvr}" = "yes"], [
+ VLC_ADD_PLUGIN([pvr])
+ ])
+ ])
+fi
AM_CONDITIONAL(HAVE_V4L2, [test "${have_v4l2}" != "no"])
dnl
--
1.7.5.4
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment