1. 08 Dec, 2011 1 commit
  2. 01 Dec, 2011 1 commit
    • Steven Walters's avatar
      YUV range detection and support for x264CLI · 6767f967
      Steven Walters authored
      Two new options: --input-range and --range.
      --input-range forces the range of the input in case of misdetection; auto by default.
      -- range sets the range of the output; x264cli will convert if necessary, TV by default.
      --fullrange is now removed as a CLI option (but the libx264 API is unchanged).
      6767f967
  3. 11 Nov, 2011 1 commit
  4. 22 Oct, 2011 2 commits
  5. 21 Sep, 2011 2 commits
    • Henrik Gramner's avatar
      4:2:2 encoding support · 5b0cb86f
      Henrik Gramner authored
      5b0cb86f
    • Loren Merritt's avatar
      SSSE3/SSE4 9-way fully merged i4x4 analysis (sad/satd_x9) · 3d82e875
      Loren Merritt authored
      i4x4 analysis cycles (per partition):
      penryn   sandybridge
      184-> 75  157-> 54  preset=superfast (sad)
      281->165  225->124  preset=faster    (satd with early termination)
      332->165  263->124  preset=medium
      379->165  297->124  preset=slower    (satd without early termination)
      
      This is the first code in x264 that intentionally produces different behavior
      on different cpus: satd_x9 is implemented only on ssse3+ and checks all intra
      directions, whereas the old code (on fast presets) may early terminate after
      checking only some of them. There is no systematic difference on slow presets,
      though they still occasionally disagree about tiebreaks.
      
      For ease of debugging, add an option "--cpu-independent" to disable satd_x9
      and any analogous future code.
      3d82e875
  6. 22 Jul, 2011 2 commits
  7. 10 Jul, 2011 2 commits
  8. 12 May, 2011 1 commit
  9. 13 Apr, 2011 1 commit
    • Fiona Glaser's avatar
      Consolidate Blu-ray hacks into --bluray-compat · e54ea0c8
      Fiona Glaser authored
      This option is now required for Blu-ray compatibility.
      --open-gop bluray is now gone (using bluray-compat and open-gop implies a Blu-ray compatible open-gop).
      This option doesn't automatically enforce every aspect of Blu-ray compatibility (e.g. resolution, framerate, level, etc).
      e54ea0c8
  10. 12 Apr, 2011 2 commits
  11. 24 Mar, 2011 3 commits
  12. 07 Feb, 2011 2 commits
  13. 05 Feb, 2011 1 commit
  14. 29 Jan, 2011 1 commit
  15. 25 Jan, 2011 3 commits
  16. 14 Dec, 2010 2 commits
  17. 25 Nov, 2010 3 commits
  18. 19 Nov, 2010 1 commit
  19. 14 Nov, 2010 1 commit
  20. 10 Nov, 2010 1 commit
    • Fiona Glaser's avatar
      Improve quantizer handling · 2f2ab0fa
      Fiona Glaser authored
      The default value for i_qpplus1 in x264_picture_t is now X264_QP_AUTO.  This is currently 0, but may change in the future.
      qpfiles no longer use -1 to indicate "auto"; QP is just omitted.  The old method should still work though.
      
      CRF values now make sense in high bit depth mode.
      --qp should be used for lossless mode, not --crf.
      --crf 0 will still work as expected in 8-bit mode, but won't be lossless with higher bit depths.
      Add bit depth to statsfiles.
      
      These changes are required to make the QP interface sensible in combination with high bit depth.
      2f2ab0fa
  21. 10 Oct, 2010 3 commits
    • Yusuke Nakamura's avatar
      Move DTS compression from libx264 to x264cli · e4b44c2e
      Yusuke Nakamura authored
      DTS compression is an ugly stupid hack and starting to encroach on unrelated areas like VBV.
      Some people want it in the mp4 muxer for devices and/or splitters that don't support Edit Boxes.
      We just say "throw these broken devices out the window".
      DTS compression will remain as a muxer option, --dts-compress, at the user's own risk.
      This option is disabled by default.
      e4b44c2e
    • Anton Mitrofanov's avatar
      Various cosmetics · 34b590b1
      Anton Mitrofanov authored
      Exorcise some CamelCase.
      34b590b1
    • Fiona Glaser's avatar
      Make sigint handler variable volatile · 91b83f58
      Fiona Glaser authored
      Didn't actually cause any problems, but is necessary because it can be modified by another thread (the signal call).
      91b83f58
  22. 28 Sep, 2010 2 commits
  23. 27 Sep, 2010 1 commit
  24. 19 Sep, 2010 1 commit
    • James Darnley's avatar
      Add --disable-gpl option to configure · 3145e67d
      James Darnley authored
      Used for commercially-licensed versions of x264.
      Doesn't currently change anything, but may be used to disable GPL-only CLI tools, such as video filters, in the future.
      Also print the x264 license and libavformat license in version info.
      3145e67d