Commit bbc68bea authored by Eric Petit's avatar Eric Petit

Check version of nasm on OS X / Intel


git-svn-id: svn://svn.videolan.org/x264/trunk@615 df754926-b1dd-0310-bc7b-ec298dee348c
parent b630af6c
......@@ -182,6 +182,21 @@ case "${MACHINE%%-*}" in
;;
esac
# check requirements
if [ $SYS = MACOSX -a $ARCH = X86 ]
then
# we want Apple's nasm from Xcode 2.4.1 or later
NASM_BUILD_REQUIRED=11
NASM_BUILD=`nasm -v|grep "Apple Computer"|sed 's/.*build \([0-9]*\).*/\1/'`
if [ $NASM_BUILD -lt $NASM_BUILD_REQUIRED ]
then
echo "Your version of 'nasm' is too old."
echo "Please install Xcode 2.4.1 or later."
exit 1
fi
fi
CFLAGS="$CFLAGS -DARCH_$ARCH -DSYS_$SYS"
# parse options
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment