INSTALL.md 898 Bytes
Newer Older
1
# Building VLMC
2

3 4
## Dependencies
* Latest version of VLC installed (from the git repository)
luyikei's avatar
luyikei committed
5 6 7 8
* Qt framework >= 5.6.0
* MLT >= 6.4.0
* medialibrary
* libvlcpp
9 10


luyikei's avatar
luyikei committed
11
## Install VLC
12

luyikei's avatar
luyikei committed
13
	See https://wiki.videolan.org/Category:Building/
14

luyikei's avatar
luyikei committed
15
## Install libvlcpp
16

luyikei's avatar
luyikei committed
17 18 19 20 21
	git clone https://code.videolan.org/videolan/libvlcpp.git
	cd libvlcpp
	./bootstrap
	./configure
	sudo make install
22 23


luyikei's avatar
luyikei committed
24
## Install medialibrary
25

luyikei's avatar
luyikei committed
26 27 28 29 30 31
	git clone https://code.videolan.org/videolan/medialibrary.git
	cd medialibrary
	./bootstrap
	./configure
	make
	sudo make install
32

luyikei's avatar
luyikei committed
33
## Install MLT
34

luyikei's avatar
luyikei committed
35
	git clone https://github.com/mltframework/mlt.git
luyikei's avatar
luyikei committed
36
	cd mlt
luyikei's avatar
luyikei committed
37 38 39
	./configure
	make
	sudo make install
40

luyikei's avatar
luyikei committed
41
## Build VLMC
42

luyikei's avatar
luyikei committed
43
	git clone https://code.videolan.org/videolan/vlmc.git
luyikei's avatar
luyikei committed
44
	cd vlmc
luyikei's avatar
luyikei committed
45 46 47
	./bootstrap
	./configure
	make
48

49
## Running VLMC
50 51

	./vlmc
52

53
## Issues
54

55
If you run into problems, you can ask for help on <vlmc-devel@videolan.org> and
56
IRC channel #vlmc on Freenode.