Commit 3ad6afbd authored by Geoffrey Métais's avatar Geoffrey Métais

Fix libraries version

parent 35262381
...@@ -36,17 +36,18 @@ ext { ...@@ -36,17 +36,18 @@ ext {
compileSdkVersion = 28 compileSdkVersion = 28
androidxCoreVersion = '1.0.1' androidxCoreVersion = '1.0.1'
androidxVersion = '1.0.0' androidxVersion = '1.0.0'
androidxAnnotationVersion = '1.0.1'
androidxAppcompatVersion = '1.0.2' androidxAppcompatVersion = '1.0.2'
constraintLayoutVersion = '2.0.0-alpha3' constraintLayoutVersion = '1.1.3'
archVersion = '2.0.0' archVersion = '2.0.0'
roomVersion = '2.1.0-alpha03' roomVersion = '2.0.0'
pagingVersion = '2.1.0-rc01' pagingVersion = '2.0.0'
junitVersion = '4.12' junitVersion = '4.12'
mockito = '2.8.9' mockito = '2.8.9'
powerMock = '1.7.4' powerMock = '1.7.4'
retrofit = '2.4.0' retrofit = '2.4.0'
espressoVersion = '3.1.0-beta02' espressoVersion = '3.1.1'
supportTest = '1.1.0-beta02' supportTest = '1.1.0'
// versionCode scheme is T M NN RR AA // versionCode scheme is T M NN RR AA
// T: Target/Flavour (1 for Android, 2 for Chrome?) // T: Target/Flavour (1 for Android, 2 for Chrome?)
// M: Major version from 0 to 9 // M: Major version from 0 to 9
......
...@@ -60,7 +60,7 @@ clean { ...@@ -60,7 +60,7 @@ clean {
} }
dependencies { dependencies {
api "androidx.annotation:annotation:$rootProject.ext.androidxVersion" api "androidx.annotation:annotation:$rootProject.ext.androidxAnnotationVersion"
api "androidx.legacy:legacy-support-v4:$rootProject.ext.androidxVersion" api "androidx.legacy:legacy-support-v4:$rootProject.ext.androidxVersion"
} }
......
...@@ -36,7 +36,6 @@ dependencies { ...@@ -36,7 +36,6 @@ dependencies {
testImplementation "junit:junit:$rootProject.ext.junitVersion" testImplementation "junit:junit:$rootProject.ext.junitVersion"
androidTestImplementation "androidx.test:runner:$rootProject.ext.supportTest" androidTestImplementation "androidx.test:runner:$rootProject.ext.supportTest"
androidTestImplementation "androidx.test.espresso:espresso-core:$rootProject.espressoVersion" androidTestImplementation "androidx.test.espresso:espresso-core:$rootProject.espressoVersion"
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
} }
repositories { repositories {
mavenCentral() mavenCentral()
......
...@@ -214,7 +214,7 @@ dependencies { ...@@ -214,7 +214,7 @@ dependencies {
// AppCompat // AppCompat
implementation "androidx.recyclerview:recyclerview:$rootProject.ext.androidxVersion" implementation "androidx.recyclerview:recyclerview:$rootProject.ext.androidxVersion"
implementation "com.google.android.material:material:$rootProject.ext.androidxVersion" implementation "com.google.android.material:material:$rootProject.ext.androidxVersion"
implementation "androidx.annotation:annotation:$rootProject.ext.androidxVersion" implementation "androidx.annotation:annotation:$rootProject.ext.androidxAnnotationVersion"
implementation "androidx.preference:preference:$rootProject.ext.androidxVersion" implementation "androidx.preference:preference:$rootProject.ext.androidxVersion"
implementation "androidx.constraintlayout:constraintlayout:$rootProject.ext.constraintLayoutVersion" implementation "androidx.constraintlayout:constraintlayout:$rootProject.ext.constraintLayoutVersion"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment