Commit 2b16e8f2 authored by Thomas Guillem's avatar Thomas Guillem Committed by Geoffrey Métais

compile-libvlc: force NDK14

cf. comment

(cherry picked from commit 0315a5b9)
parent d2a88177
......@@ -281,14 +281,17 @@ VLC_CONTRIB="$VLC_SRC_DIR/contrib/$TARGET_TUPLE"
# try to detect NDK version
REL=$(grep -o '^Pkg.Revision.*[0-9]*.*' $ANDROID_NDK/source.properties |cut -d " " -f 3 | cut -d "." -f 1)
if [ "$REL" -ge 14 ]; then
# NDK 15 and after drops support for old android platforms (bellow
# ANDROID_API=14) but these platforms are still supported by VLC 3.0.
# TODO: Switch to NDK 15 when we drop support for old android plaftorms (for VLC 4.0)
if [ "$REL" -eq 14 ]; then
if [ "${HAVE_64}" = 1 ];then
ANDROID_API=21
else
ANDROID_API=9
fi
else
echo "You need the NDKv14 or later"
echo "NDK v14 needed, cf. https://developer.android.com/ndk/downloads/older_releases.html#ndk-14-downloads"
exit 1
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment