Commit 5e6d74cc authored by Felix Paul Kühne's avatar Felix Paul Kühne

extras/mac: fix compilation if SDK is not stored in default location

Note that there is nothing wrong with execution on 10.6 if linked against the 10.7 SDK as long as the minimal macosx version is specified correctly
parent 0648e6f4
#!/bin/sh
OSX_VERSION="10.7"
SDKROOT=`xcode-select -print-path`/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$OSX_VERSION.sdk
set -e
usage()
......@@ -60,6 +63,9 @@ if [ "x$1" != "x" ]; then
exit 1
fi
export OSX_VERSION
export SDKROOT
# Get root dir
spushd .
npapi_root_dir=`pwd`
......@@ -127,7 +133,6 @@ cd 64build
--disable-macosx \
--enable-merge-ffmpeg \
--disable-growl \
--enable-minimal-macosx \
--enable-faad \
--enable-flac \
--enable-theora \
......@@ -152,7 +157,7 @@ cd 64build
--disable-sdl \
--disable-sdl-image \
--disable-macosx-vlc-app \
--with-macosx-sdk=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk \
--with-macosx-sdk=$SDKROOT \
--with-macosx-version-min=10.6 \
--prefix=${PREFIX} > ${out}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment