Commit 33ce3829 authored by Marvin Scholz's avatar Marvin Scholz Committed by Ronald S. Bultje

build: Change required nasm version to 2.13.02

parent 46435a53
Pipeline #3968 passed with stages
in 5 minutes and 5 seconds
...@@ -70,7 +70,7 @@ The [VideoLAN Code of Conduct](https://wiki.videolan.org/CoC) applies to this pr ...@@ -70,7 +70,7 @@ The [VideoLAN Code of Conduct](https://wiki.videolan.org/CoC) applies to this pr
# Compile # Compile
1. Install [Meson](https://mesonbuild.com/) (0.47 or higher), [Ninja](https://ninja-build.org/), and, for x86* targets, [nasm](https://nasm.us/) (2.13 or higher) 1. Install [Meson](https://mesonbuild.com/) (0.47 or higher), [Ninja](https://ninja-build.org/), and, for x86* targets, [nasm](https://nasm.us/) (2.13.02 or higher)
2. Run `meson build --buildtype release` 2. Run `meson build --buildtype release`
3. Build with `ninja -C build` 3. Build with `ninja -C build`
......
...@@ -311,8 +311,8 @@ if is_asm_enabled and host_machine.cpu_family().startswith('x86') ...@@ -311,8 +311,8 @@ if is_asm_enabled and host_machine.cpu_family().startswith('x86')
nasm_r = run_command(nasm, '-v') nasm_r = run_command(nasm, '-v')
out = nasm_r.stdout().strip().split() out = nasm_r.stdout().strip().split()
if out[1].to_lower() == 'version' if out[1].to_lower() == 'version'
if out[2].version_compare('<2.13') if out[2].version_compare('<2.13.02')
error('nasm 2.13 or later is required, found nasm @0@'.format(out[2])) error('nasm 2.13.02 or later is required, found nasm @0@'.format(out[2]))
endif endif
else else
error('unexpected nasm version string: @0@'.format(nasm_r.stdout())) error('unexpected nasm version string: @0@'.format(nasm_r.stdout()))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment