Commit 6bbac577 authored by Geoffrey Métais's avatar Geoffrey Métais

Insert variable to groovy strings for versions

Allows Android Studio to hint for available library upgrades
parent 579b288d
......@@ -46,6 +46,6 @@ task generateSources (type: Jar) {
dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
compile 'com.android.support:appcompat-v7:'+rootProject.ext.appCompatVersion
compile "com.android.support:appcompat-v7:$rootProject.ext.appCompatVersion"
testCompile 'junit:junit:4.12'
}
......@@ -104,5 +104,5 @@ clean {
}
dependencies {
compile 'com.android.support:support-annotations:'+rootProject.ext.appCompatVersion
compile "com.android.support:support-annotations:$rootProject.ext.appCompatVersion"
}
......@@ -63,7 +63,7 @@ clean {
dependencies {
compile project(':libvlc')
compile 'com.android.support:support-v4:'+rootProject.ext.appCompatVersion
compile 'com.android.support:support-compat:'+rootProject.ext.appCompatVersion
compile 'com.android.support:support-fragment:'+rootProject.ext.appCompatVersion
compile "com.android.support:support-v4:$rootProject.ext.appCompatVersion"
compile "com.android.support:support-compat:$rootProject.ext.appCompatVersion"
compile "com.android.support:support-fragment:$rootProject.ext.appCompatVersion"
}
\ No newline at end of file
......@@ -180,14 +180,13 @@ dependencies {
compile project(':medialibrary')
compile project(':api')
compile project(':axmlrpc')
compile 'com.android.support:appcompat-v7:'+rootProject.ext.appCompatVersion
compile 'com.android.support:recyclerview-v7:'+rootProject.ext.appCompatVersion
compile 'com.android.support:design:'+rootProject.ext.appCompatVersion
compile 'com.android.support:support-annotations:'+rootProject.ext.appCompatVersion
compile 'com.android.support:preference-v7:'+rootProject.ext.appCompatVersion
compile 'com.android.support:leanback-v17:'+rootProject.ext.appCompatVersion
compile 'com.android.support:preference-leanback-v17:'+rootProject.ext.appCompatVersion
compile 'com.android.support.constraint:constraint-layout:'+rootProject.ext.constraintLayoutVersion
compile "com.android.support:recyclerview-v7:$rootProject.ext.appCompatVersion"
compile "com.android.support:design:$rootProject.ext.appCompatVersion"
compile "com.android.support:support-annotations:$rootProject.ext.appCompatVersion"
compile "com.android.support:preference-v7:$rootProject.ext.appCompatVersion"
compile "com.android.support:leanback-v17:$rootProject.ext.appCompatVersion"
compile "com.android.support:preference-leanback-v17:$rootProject.ext.appCompatVersion"
compile "com.android.support.constraint:constraint-layout:$rootProject.ext.constraintLayoutVersion"
testCompile 'junit:junit:4.12'
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment