Commit 451c24ef authored by Geoffrey Métais's avatar Geoffrey Métais

Upgrade AGP, Arch and Kotlin

parent 3d000c09
...@@ -27,7 +27,6 @@ apply plugin: 'com.jfrog.bintray' ...@@ -27,7 +27,6 @@ apply plugin: 'com.jfrog.bintray'
android { android {
compileSdkVersion rootProject.ext.compileSdkVersion compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
defaultConfig { defaultConfig {
versionCode 1 versionCode 1
......
// Top-level build file where you can add configuration options common to all sub-projects/modules. // Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript { buildscript {
ext.android_plugin_version = '3.0.1' ext.android_plugin_version = '3.1.0'
ext.kotlin_version = '1.2.30' ext.kotlin_version = '1.2.31'
ext.kotlinx_version = '0.22.2' ext.kotlinx_version = '0.22.2'
repositories { repositories {
flatDir dirs: "gradle/plugins" flatDir dirs: "gradle/plugins"
...@@ -26,8 +26,7 @@ allprojects { ...@@ -26,8 +26,7 @@ allprojects {
ext { ext {
appCompatVersion = '27.1.0' appCompatVersion = '27.1.0'
constraintLayoutVersion = '1.1.0-beta6' constraintLayoutVersion = '1.1.0-beta6'
archVersion = '1.1.0' archVersion = '1.1.1'
buildToolsVersion = "27.0.2"
compileSdkVersion = 26 compileSdkVersion = 26
minSdkVersion = 14 minSdkVersion = 14
targetSdkVersion = 26 targetSdkVersion = 26
......
...@@ -4,7 +4,6 @@ import com.android.builder.core.DefaultManifestParser ...@@ -4,7 +4,6 @@ import com.android.builder.core.DefaultManifestParser
android { android {
compileSdkVersion rootProject.ext.compileSdkVersion compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
sourceSets { sourceSets {
main { main {
......
...@@ -23,7 +23,6 @@ ...@@ -23,7 +23,6 @@
apply plugin: 'com.android.library' apply plugin: 'com.android.library'
android { android {
compileSdkVersion rootProject.ext.compileSdkVersion compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
sourceSets { sourceSets {
main { main {
......
...@@ -13,7 +13,6 @@ android { ...@@ -13,7 +13,6 @@ android {
} }
compileSdkVersion rootProject.ext.compileSdkVersion compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
flavorDimensions "target", "abi" flavorDimensions "target", "abi"
...@@ -191,7 +190,6 @@ dependencies { ...@@ -191,7 +190,6 @@ dependencies {
implementation project(':api') implementation project(':api')
implementation project(':axmlrpc') implementation project(':axmlrpc')
// AppCompat // AppCompat
kapt 'com.android.databinding:compiler:3.0.1'
implementation "com.android.support:recyclerview-v7:$rootProject.ext.appCompatVersion" implementation "com.android.support:recyclerview-v7:$rootProject.ext.appCompatVersion"
implementation "com.android.support:design:$rootProject.ext.appCompatVersion" implementation "com.android.support:design:$rootProject.ext.appCompatVersion"
implementation "com.android.support:support-annotations:$rootProject.ext.appCompatVersion" implementation "com.android.support:support-annotations:$rootProject.ext.appCompatVersion"
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment