Commit f4fd60fe authored by Pierre Ynard's avatar Pierre Ynard Committed by Jean-Baptiste Kempf

WinCE: Require a recent enough mingwce to fix *printf problems

This just in: CeGCC has a MinGW with working replacement *printf
functions. Just like for mingw32, require (and allow building with) a
recent enough version of mingwce.

Since MinGW is patched by CeGCC, this check is not strictly sufficient;
but at least this allows to have working WinCE builds again.
Signed-off-by: Rémi Denis-Courmont's avatarRémi Denis-Courmont <remi@remlab.net>
parent 48260d39
......@@ -471,7 +471,7 @@ VLC_ADD_CFLAGS([libvlccore],[${INCICONV}])
VLC_ADD_LIBS([libvlccore],[${LTLIBICONV}])
dnl Check for broken versions of mingw-runtime compatability library
AS_IF([test "${SYS}" = "mingw32"], [
AS_IF([test "${SYS}" = "mingw32" -o "${SYS}" = "mingwce"], [
AC_MSG_CHECKING(for broken mingw-runtime)
AC_PREPROC_IFELSE([
#include <_mingw.h>
......
......@@ -26,19 +26,6 @@
#ifndef LIBVLC_FIXUPS_H
# define LIBVLC_FIXUPS_H 1
#ifdef __MINGW32_VERSION
# if __MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION < 14
# error This mingw-runtime is too old, it has a broken vsnprintf
# endif
/* mingw-runtime provides the whole printf family in a c99 compliant way. */
/* the way to enable this is to define __USE_MINGW_ANSI_STDIO, or something
* such as _ISOC99_SOURCE; the former is done by configure.ac */
/* This isn't done here, since some modules don't include config.h and
* therefore this as the first include file */
#elif defined UNDER_CE
# error Window CE support for *printf needs fixing.
#endif
#if !defined (HAVE_GMTIME_R) || !defined (HAVE_LOCALTIME_R)
# include <time.h> /* time_t */
#endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment