Commit b8869f97 authored by Rafaël Carré's avatar Rafaël Carré

Relax requirements for FFmpeg hwaccel

It doesn't error out anymore since 5edd1f62ca1
parent bfca1ad0
......@@ -2371,7 +2371,9 @@ AS_IF([test "${have_vaapi}" = "yes" -a "${have_avcodec}" = "yes"], [
case "${avfork}" in
ffmpeg)
PKG_CHECK_EXISTS([libavcodec >= 57.10.100], [
AC_MSG_ERROR([VA API requires FFmpeg libavcodec < 57.10 or libav.])
PKG_CHECK_EXISTS([libavcodec <= 57.12.100], [
AC_MSG_ERROR([VA API requires FFmpeg libavcodec < 57.10 or > 57.12 or libav.])
])
])
;;
esac
......@@ -2405,7 +2407,9 @@ AS_IF([test "${enable_dxva2}" != "no"], [
case "${avfork}" in
ffmpeg)
PKG_CHECK_EXISTS([libavcodec >= 57.10.100], [
AC_MSG_ERROR([DXVA2 requires FFmpeg libavcodec < 57.10 or libav.])
PKG_CHECK_EXISTS([libavcodec <= 57.12.100], [
AC_MSG_ERROR([DXVA2 requires FFmpeg libavcodec < 57.10 or > 57.12 or libav.])
])
])
;;
esac
......@@ -3113,7 +3117,9 @@ AS_IF([test "${have_vdpau}" = "yes" -a "${have_avcodec}" = "yes"], [
libav) av_vdpau_ver="55.26.0" ;;
ffmpeg) av_vdpau_ver="55.42.100"
PKG_CHECK_EXISTS([libavcodec >= 57.10.100], [
AC_MSG_ERROR([VDPAU requires FFmpeg libavcodec < 57.10 or libav.])
PKG_CHECK_EXISTS([libavcodec <= 57.12.100], [
AC_MSG_ERROR([VDPAU requires FFmpeg libavcodec < 57.10 or > 57.12 or libav.])
])
])
;;
esac
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment