Commit 53d723d5 authored by Ilkka Ollakka's avatar Ilkka Ollakka

configure: require libavcodec >= 57

check for ffmpeg/libav versions
parent e08e6f2f
......@@ -2314,10 +2314,12 @@ dnl
AC_ARG_ENABLE(avcodec,
[ --enable-avcodec libavcodec codec (default enabled)])
AS_IF([test "${enable_avcodec}" != "no"], [
PKG_CHECK_MODULES(AVCODEC,[libavcodec >= 55.0.0 libavutil >= 52.0.0], [
dnl PKG_CHECK_EXISTS([libavcodec < 56],, [
dnl AC_MSG_ERROR([libavcodec versions 56 and later are not supported yet.])
dnl ])
dnl We need >=57.16.0 from libav or >=57.37.100 from ffmpeg
case "${avfork}" in
libav) av_codec_ver="57.16.0" ;;
ffmpeg) av_codec_ver="57.37.100" ;;
esac
PKG_CHECK_MODULES(AVCODEC,[libavcodec >= ${av_codec_ver} libavutil >= 52.0.0], [
VLC_SAVE_FLAGS
CPPFLAGS="${CPPFLAGS} ${AVCODEC_CFLAGS}"
CFLAGS="${CFLAGS} ${AVCODEC_CFLAGS}"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment