Commit 12246fe9 authored by Sam Hocevar's avatar Sam Hocevar

* THANKS: spelling fixes.

  * configure.ac:
    + Added curly braces around variables.
    + Got rid of the "x$foo" constructs.
    + Renamed *_plugin conditionals into *_p.
  * debian/changelog:
    + Fixed a duplicate entry.
    + Added an entry for an old Debian upload that fixed #117180.
  * debian/control:
    + Added a build dependency on libimlib2-dev for skins.
  * debian/rules:
    + Activated support for skins.
parent a0f89f4d
$Id: THANKS,v 1.8 2003/05/24 11:53:12 sam Exp $
$Id: THANKS,v 1.9 2003/06/21 20:45:53 sam Exp $
VLC makes extensive use of the following persons' code:
......@@ -27,7 +27,7 @@ Davor Orel <syntheticamac at yahoo.it> - Mac OS X icons
Emmanuel Blindauer <manu@agat.net> - aRts audio output
Espen Skoglund <esk@ira.uka.de> - FreeBSD autoconf and Makefile patches
Ethan C. Baldridge <BaldridgeE@cadmus.com> - directory browsing code
Felix Khne <fk@aenneburghardt.de> - german translation
Felix Khne <fk@aenneburghardt.de> - German translation
Fumio Nakayama <endymion@ca2.so-net.ne.jp> - Japanese translation
Haakon Meland Eriksen - Norwegian translation
Hans-Peter Jansen <hpj@urpla.net> - patch for module options handling
......@@ -58,9 +58,9 @@ Rudolf Cornelissen <rag.cornelissen@inter.nl.net> - BeOS fixes
Sebastien Chaumat <Sebastien.Chaumat@ens-lyon.fr> - YOPY port tests
Steve Brown <sbrown@cortland.com> - fix for optional PES size bug
Steven M. Schultz <sms@TO.GD-ES.COM> - BSD/OS port
Thomas Graf <tgraf@europe.com> - gettext support, german translation
Thomas Graf <tgraf@europe.com> - gettext support, German translation
Thomas L. Wood <twood@lucent.com> - fixed a bug in QuantMatrixExtension
Valek Filippov <frob@df.ru> - russian translation
Valek Filippov <frob@df.ru> - Russian translation
Vladimir Chernyshov <greengrass@writeme.com> - MMX motion optimizations
Wade Majors <guru@startrek.com> - BeOS icon integration, debugging and fixes
Watanabe Go <go@dsl.gr.jp> - fix for non-ASCII filenames
......
#! /bin/sh
## bootstrap file for the VLC media player
## $Id: bootstrap,v 1.49 2003/06/21 17:04:20 sam Exp $
## $Id: bootstrap,v 1.50 2003/06/21 20:45:53 sam Exp $
##
## Authors: Samuel Hocevar <sam@zoy.org>
......@@ -91,8 +91,8 @@ EOF
NODIST=''; else
NODIST='#'; fi
cat >> m4/vlc.m4 << EOF
AM_CONDITIONAL(${mod}_plugin, test x\$${mod}_plugin = xyes)
AM_CONDITIONAL(${mod}_builtin, test x\$${mod}_builtin = xyes)
AM_CONDITIONAL(${mod}_p, test x\$${mod}_p = xyes)
AM_CONDITIONAL(${mod}_b, test x\$${mod}_b = xyes)
EOF
# Generation of Modules.am
# ~~~~~~~~~~~~~~~~~~~~~~~~
......@@ -104,14 +104,14 @@ EOF
cat >> Modules.am << EOF
# The ${mod} plugin
if ${mod}_plugin
if ${mod}_p
if UNTRUE
L_${mod}_p = ${dir}/lib${mod}_plugin.a
endif
D_${mod}_p = ${dir}/lib${mod}_plugin\$(LIBEXT)
${NODIST}B_${mod}_p = \$(nodist_SOURCES_${mod})
endif
if ${mod}_builtin
if ${mod}_b
L_${mod}_b = ${dir}/lib${mod}.a
F_${mod}_b = \$(LDFLAGS_${mod})
if BUILD_MOZILLA
......
This diff is collapsed.
......@@ -211,6 +211,12 @@ vlc (0.2.91-1) unstable; urgency=low
-- Samuel Hocevar <sam@zoy.org> Mon, 12 Nov 2001 17:14:29 +0100
vlc (0.2.90-3) unstable; urgency=low
* Added stricter Build-Depends on libsdl1.2-dev (Closes: #117180).
-- Samuel Hocevar <sam@zoy.org> Fri, 26 Oct 2001 16:06:01 +0200
vlc (0.2.90-2) unstable; urgency=low
* Various upstream bugfixes.
......@@ -335,7 +341,7 @@ vlc (0.2.60-1) unstable; urgency=low
-- Samuel Hocevar <sam@zoy.org> Wed, 14 Feb 2001 08:33:46 +0100
vlc (0.2.50-1) unstable; urgency=low
vlc (0.2.50nocss-1) unstable; urgency=low
* Only build vlc-glide under x86 (Closes: #84046).
* Switched PentiumPro optimization off (Closes: #83707).
......
......@@ -2,7 +2,7 @@ Source: vlc
Section: graphics
Priority: optional
Maintainer: Sam Hocevar (Debian packages) <sam+deb@zoy.org>
Build-Depends: debhelper (>=3.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0)
Build-Depends: debhelper (>=3.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0), libimlib2-dev
Build-Conflicts: libmpeg2-dev, libmpeg2-0-dev, libmpeg2-1-dev, libmpeg2-2-dev, libmpeg2-3-dev
Standards-Version: 3.5.10
......
......@@ -41,6 +41,9 @@ CONFIG_FLAGS += \
--enable-wxwindows \
--enable-slp \
--enable-flac \
--enable-skins \
--disable-basic-skins \
--disable-freetype \
$(NULL)
# These ones are currently shipped with VLC
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment