Commit f9d095a6 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

--disable-avcodec implies --disable-libva

Don't force an explicit --disable-libva. This was especially silly on
non-libVA platforms.
parent 9dd8de3f
......@@ -2978,7 +2978,9 @@ AS_IF([test "${enable_libva}" != "no"], [
[AC_MSG_WARN([libva not found ])])
])
],[
AC_MSG_ERROR([libva VAAPI support depends on libavcodec. You cannot use --disable-avcodec.])
AS_IF([test "x${enable_libva}" != "x"], [
AC_MSG_ERROR([--enable-libva and --disable-avcodec options are mutually exclusive.])
])
])
])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment