Commit f7a43ee5 authored by Martin Storsjö's avatar Martin Storsjö
Browse files

contribs: Add a patch for libpng for building with automake 1.11



automake 1.12 changed the default for tests, requiring projects
that need serial test execution to add an option for setting this.
This option isn't available on automake 1.11, so those projects
became incompatible with automake 1.11 once they got ready for 1.12.
This obviously isn't an issue in most cases where the prebuilt
configure is good enough.

Since we don't run the tests in contribs, just remove this option
for now, to allow building with both automake 1.11 and 1.12.
Signed-off-by: Martin Storsjö's avatarMartin Storsjö <martin@martin.st>
parent 2be7fadd
diff -ur png/configure.ac png.new/configure.ac
--- png/configure.ac 2013-06-27 06:25:42.000000000 +0300
+++ png.new/configure.ac 2013-07-09 14:19:02.953919579 +0300
@@ -19,7 +19,7 @@
dnl Version number stuff here:
AC_INIT([libpng], [1.5.17], [png-mng-implement@lists.sourceforge.net])
-AM_INIT_AUTOMAKE([serial-tests])
+AM_INIT_AUTOMAKE
dnl stop configure from automagically running automake
AM_MAINTAINER_MODE
......@@ -15,6 +15,7 @@ $(TARBALLS)/libpng-$(PNG_VERSION).tar.bz2:
png: libpng-$(PNG_VERSION).tar.bz2 .sum-png
$(UNPACK)
$(APPLY) $(SRC)/png/winrt.patch
$(APPLY) $(SRC)/png/automake.patch
$(MOVE)
DEPS_png = zlib $(DEPS_zlib)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment