Commit f287c93d authored by Rafaël Carré's avatar Rafaël Carré

Adds ncurses compiled with wide characters support to contribs for MacOSX

parent fb2512ec
......@@ -5,7 +5,7 @@ all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .cddb .cdio .vcdimager \
.SDL_image .glib .gecko .mpcdec .dirac_encoder .dirac_decoder \
.dca .tag .x264 .goom2k4 .lua .zvbi .fontconfig .aclocal
.dca .tag .x264 .goom2k4 .lua .zvbi .fontconfig .ncurses .aclocal
# .expat .clinkcc don't work with SDK yet
# .glib .IDL .gecko are required to build the mozilla plugin
# .mozilla will build an entire mozilla. it can be used if we need to create a new .gecko package
......
......@@ -1137,7 +1137,7 @@ libdvbpsi: libdvbpsi4-$(LIBDVBPSI_VERSION).tar.gz
CLEAN_FILE += .dvbpsi
CLEAN_PKG += libdvbpsi
DISTCLEAN_PKG += libdvbpsi3-$(LIBDVBPSI_VERSION).tar.gz
DISTCLEAN_PKG += libdvbpsi4-$(LIBDVBPSI_VERSION).tar.gz
# ***************************************************************************
# live
......@@ -2162,6 +2162,23 @@ pthreads: pthreads-w32-$(PTHREADS_VERSION)-release.tar.gz
$(INSTALL_NAME)
touch $@
# ***************************************************************************
# ncurses library (with wide chars support)
# ***************************************************************************
ncurses-$(NCURSES_VERSION).tar.gz:
$(WGET) $(NCURSES_URL)
ncurses: ncurses-$(NCURSES_VERSION).tar.gz
$(EXTRACT_GZ)
.ncurses: ncurses
(cd $<; $(HOSTCC) ./configure $(HOSTCONF) --prefix=$(PREFIX) --without-debug --enable-widec --without-develop --without-shared && make && make install)
touch $@
CLEAN_FILE += .ncurses
CLEAN_PKG += ncurses
DISTCLEAN_PKG += ncurses-$(NCURSES_VERSION).tar.gz
# ***************************************************************************
# Some cleaning
......
......@@ -191,3 +191,5 @@ TAGLIB_VERSION=1.4
TAGLIB_URL=http://developer.kde.org/~wheeler/files/src/taglib-$(TAGLIB_VERSION).tar.gz
LUA_VERSION=5.1
LUA_URL=http://www.lua.org/ftp/lua-$(LUA_VERSION).tar.gz
NCURSES_VERSION=5.6
NCURSES_URL=$(GNU)/ncurses/ncurses-$(NCURSES_VERSION).tar.gz
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment