Commit ee5fad6a authored by Pyry Kontio's avatar Pyry Kontio Committed by Jean-Baptiste Kempf

Fix the tools bootstrap version check

It was broken when ProtoBuf 3.1 was installed system-wide, for example.

The bootstrap script that outputs which binary tools need to be installed, incorrectly
detects that Protocol Buffers 3.1 is a compatible version with 2.6. This changes the
check on the major version number to require it to be same, not just bigger,
since changes on the major version numbers might be breaking changes, as was the case
here.
Signed-off-by: Jean-Baptiste Kempf's avatarJean-Baptiste Kempf <jb@videolan.org>
parent aa3c0676
......@@ -60,7 +60,7 @@ else
needminor=`echo $2|cut -d. -f2`
needmicro=`echo $2|cut -d. -f3`
[ -z "$needmicro" ] && needmicro=0
if [ "$needmajor" -gt "$gotmajor" \
if [ "$needmajor" -ne "$gotmajor" \
-o "$needmajor" -eq "$gotmajor" -a "$needminor" -gt "$gotminor" \
-o "$needmajor" -eq "$gotmajor" -a "$needminor" -eq "$gotminor" -a "$needmicro" -gt "$gotmicro" ]
then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment