Commit e57d32f6 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

configure: FFmpeg hwaccel requires libavcodec < 57.10.100

Since n2.9-dev-1400-g31741ae, the VLC avcodec plug-in will fail to
initialize hwaccel. This is by FFmpeg design.
parent 5ff5efac
......@@ -2353,11 +2353,18 @@ AM_CONDITIONAL([HAVE_VAAPI_X11], [test "${have_vaapi_x11}" = "yes"])
have_avcodec_vaapi="no"
AS_IF([test "${have_vaapi}" = "yes" -a "${have_avcodec}" = "yes"], [
case "${avfork}" in
ffmpeg)
PKG_CHECK_EXISTS([libavcodec >= 57.10.100], [
AC_MSG_ERROR([VA API requires FFmpeg libavcodec < 57.10 or libav.])
])
;;
esac
VLC_SAVE_FLAGS
CPPFLAGS="${CPPFLAGS} ${AVCODEC_CFLAGS}"
CFLAGS="${CFLAGS} ${AVCODEC_CFLAGS}"
AC_CHECK_HEADERS([libavcodec/vaapi.h], [
AC_MSG_NOTICE([VAAPI acceleration activated])
AC_MSG_NOTICE([VA API acceleration activated])
have_avcodec_vaapi="yes"
],[
AS_IF([test -n "${enable_libva}"], [
......@@ -2380,6 +2387,13 @@ have_avcodec_dxva2="no"
AS_IF([test "${enable_dxva2}" != "no"], [
if test "${SYS}" = "mingw32"; then
AS_IF([test "x${have_avcodec}" = "xyes"], [
case "${avfork}" in
ffmpeg)
PKG_CHECK_EXISTS([libavcodec >= 57.10.100], [
AC_MSG_ERROR([DXVA2 requires FFmpeg libavcodec < 57.10 or libav.])
])
;;
esac
AC_CHECK_HEADERS(dxva2api.h,
[
AC_CHECK_HEADERS(libavcodec/dxva2.h, [
......@@ -3076,7 +3090,11 @@ have_avcodec_vdpau="no"
AS_IF([test "${have_vdpau}" = "yes" -a "${have_avcodec}" = "yes"], [
case "${avfork}" in
libav) av_vdpau_ver="55.26.0" ;;
ffmpeg) av_vdpau_ver="55.42.100" ;;
ffmpeg) av_vdpau_ver="55.42.100"
PKG_CHECK_EXISTS([libavcodec >= 57.10.100], [
AC_MSG_ERROR([VDPAU requires FFmpeg libavcodec < 57.10 or libav.])
])
;;
esac
PKG_CHECK_EXISTS([libavutil >= 52.4.0 libavcodec >= ${av_vdpau_ver}], [
have_avcodec_vdpau="yes"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment