Commit e2d3685a authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

contrib: fix ffmpeg dependencies

parent 66f52322
...@@ -26,29 +26,29 @@ ifdef BUILD_ENCODERS ...@@ -26,29 +26,29 @@ ifdef BUILD_ENCODERS
# TODO: # TODO:
#FFMPEGCONF+= --enable-libmp3lame #FFMPEGCONF+= --enable-libmp3lame
#.ffmpeg: .lame #.ffmpeg: .lame
#PKGS += lame
else else
FFMPEGCONF += --disable-encoders --disable-muxers FFMPEGCONF += --disable-encoders --disable-muxers
# XXX: REVISIT --enable-small ? # XXX: REVISIT --enable-small ?
endif endif
ifdef HAVE_CROSS_COMPILE
FFMPEGCONF += --enable-cross-compile --cross-prefix=$(HOST)-
endif
# XXX: REVISIT: gsm and vpx not used by VLC so should in PKGS?
ifneq ($(filter gsm,$(PKGS)),)
#FFMPEGCONF+= --enable-libgsm #FFMPEGCONF+= --enable-libgsm
#.ffmpeg: .gsm #.ffmpeg: .gsm
endif #PKGS += gsm
ifneq ($(filter vpx,$(PKGS)),)
#FFMPEGCONF += --enable-libvpx #FFMPEGCONF += --enable-libvpx
#.ffmpeg: .vpx #.ffmpeg: .vpx
endif #PKGS += vpx
# XXX: REVISIT # XXX: REVISIT
#ifndef HAVE_FPU #ifndef HAVE_FPU
#FFMPEGCONF+= --disable-mpegaudio-hp #FFMPEGCONF+= --disable-mpegaudio-hp
#endif #endif
ifdef HAVE_CROSS_COMPILE
FFMPEGCONF += --enable-cross-compile --cross-prefix=$(HOST)-
endif
# ARM stuff # ARM stuff
ifeq ($(ARCH),arm) ifeq ($(ARCH),arm)
FFMPEGCONF += --disable-runtime-cpudetect FFMPEGCONF += --disable-runtime-cpudetect
...@@ -73,6 +73,7 @@ ifeq ($(ARCH),x86_64) ...@@ -73,6 +73,7 @@ ifeq ($(ARCH),x86_64)
FFMPEGCONF += --cpu=core2 FFMPEGCONF += --cpu=core2
endif endif
.ffmpeg: .yasm .ffmpeg: .yasm
PKGS += yasm
endif endif
# Linux # Linux
...@@ -86,12 +87,16 @@ FFMPEGCONF += --target-os=mingw32 --enable-memalign-hack ...@@ -86,12 +87,16 @@ FFMPEGCONF += --target-os=mingw32 --enable-memalign-hack
FFMPEGCONF += --enable-w32threads \ FFMPEGCONF += --enable-w32threads \
--disable-bzlib --disable-bsfs \ --disable-bzlib --disable-bsfs \
--disable-decoder=dca --disable-encoder=vorbis --disable-decoder=dca --disable-encoder=vorbis
ifdef HAVE_WIN64 ifdef HAVE_WIN64
FFMPEGCONF += --disable-dxva2 FFMPEGCONF += --disable-dxva2
FFMPEGCONF += --cpu=athlon64 --arch=x86_64 FFMPEGCONF += --cpu=athlon64 --arch=x86_64
else # !WIN64 else # !WIN64
FFMPEGCONF += --enable-dxva2 FFMPEGCONF += --enable-dxva2
.ffmpeg: .directx .ffmpeg: .directx
PKGS += directx
FFMPEGCONF+= --cpu=i686 --arch=x86 FFMPEGCONF+= --cpu=i686 --arch=x86
endif endif
else else
...@@ -109,7 +114,7 @@ FFMPEG_CFLAGS += --std=gnu99 ...@@ -109,7 +114,7 @@ FFMPEG_CFLAGS += --std=gnu99
# Build # Build
PKGS += libav PKGS += ffmpeg
ffmpeg-$(FFMPEG_VERSION).tar.gz: ffmpeg-$(FFMPEG_VERSION).tar.gz:
$(error FFmpeg snapshot is too old, VCS must be used!) $(error FFmpeg snapshot is too old, VCS must be used!)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment