Commit cea447d3 authored by Jean-Baptiste Kempf's avatar Jean-Baptiste Kempf

Contrib libgpg-error 1.3 => 1.5. Remove unnecessary patch (integrated upstream)

parent bc4992bf
......@@ -1604,12 +1604,11 @@ CLEAN_PKG += libdc1394
DISTCLEAN_PKG += libdc1394-$(LIBDC1394_VERSION).tar.gz
# ***************************************************************************
libgpg-error-$(GPGERROR_VERSION).tar.gz:
libgpg-error-$(GPGERROR_VERSION).tar.bz2:
$(WGET) $(GPGERROR_URL)
libgpg-error: libgpg-error-$(GPGERROR_VERSION).tar.gz
$(EXTRACT_GZ)
patch -p0 < Patches/libgpg-error.patch
libgpg-error: libgpg-error-$(GPGERROR_VERSION).tar.bz2
$(EXTRACT_BZ2)
ifdef HAVE_WIN32
patch -p0 < Patches/libgpg-error-win32.patch
endif
......@@ -1624,7 +1623,7 @@ endif
CLEAN_FILE += .gpg-error
CLEAN_PKG += libgpg-error
DISTCLEAN_PKG += libgpg-error-$(GPGERROR_VERSION).tar.gz
DISTCLEAN_PKG += libgpg-error-$(GPGERROR_VERSION).tar.bz2
# ***************************************************************************
# libgcrypt
......
--- libgpg-error/src/gpg-error.c 2005-12-18 15:24:34.000000000 +0000
+++ libgpg-error.patch/src/gpg-error.c 2006-07-27 23:10:46.000000000 +0100
@@ -78,10 +78,14 @@
locale_dir = get_locale_dir ();
if (locale_dir)
{
+#ifdef ENABLE_NLS
bindtextdomain (PACKAGE, locale_dir);
+#endif
drop_locale_dir (locale_dir);
}
+#ifdef ENABLE_NLS
textdomain (PACKAGE);
+#endif
}
# ***************************************************************************
#b ***************************************************************************
# src/packages.mak : Archive locations
# ***************************************************************************
# Copyright (C) 2003 - 2006 the VideoLAN team
......@@ -122,8 +122,8 @@ CDIO_VERSION=0.78.2
CDIO_URL=$(GNU)/libcdio/libcdio-$(CDIO_VERSION).tar.gz
PNG_VERSION=1.2.16
PNG_URL=$(SF)/libpng/libpng-$(PNG_VERSION).tar.bz2
GPGERROR_VERSION=1.3
GPGERROR_URL=http://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-$(GPGERROR_VERSION).tar.gz
GPGERROR_VERSION=1.5
GPGERROR_URL=http://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-$(GPGERROR_VERSION).tar.bz2
#GPGERROR_URL=$(VIDEOLAN)/testing/contrib/libgpg-error-$(GPGERROR_VERSION).tar.gz
GCRYPT_VERSION=1.2.3
GCRYPT_URL=http://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-$(GCRYPT_VERSION).tar.bz2
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment