Commit ba62457a authored by Pierre d'Herbemont's avatar Pierre d'Herbemont

extras/contrib/bootstrap: Use space to ident rather than tabs.

parent b2cb8c3e
......@@ -51,8 +51,8 @@ fi
rm -f config.mak
{
echo "# Automatically generated by bootstrap."
echo "# Make changes if you know what you're doing."
echo "# Automatically generated by bootstrap."
echo "# Make changes if you know what you're doing."
} > config.mak
rm -f distro.mak
......@@ -92,59 +92,59 @@ esac
case $HOST in
ppc-darwin)
# Mac OS X < 10.4
echo "Your version of Mac OS X is too old!" >&2
echo "Compiling VLC requires 10.4.x or later" >&2
exit 1
;;
echo "Your version of Mac OS X is too old!" >&2
echo "Compiling VLC requires 10.4.x or later" >&2
exit 1
;;
powerpc-apple-darwin8)
# Mac OS X 10.4
# Makefile cross compiling is only supported with gcc-4.0
# ENVP defines the oldest environment on which the program will be able to run
# SDK 10.2.8 requires gcc-3.3 (so we cannot use that SDK)
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -arch ppc -mtune=G4"
EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -arch ppc -mtune=G4"
EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
;;
i686-apple-darwin8)
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
echo "HAVE_DARWIN_OS_ON_INTEL = 1" >> config.mak
echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -march=pentium-m -mtune=prescott"
EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
echo "HAVE_DARWIN_OS_ON_INTEL = 1" >> config.mak
echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -march=pentium-m -mtune=prescott"
EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
;;
powerpc-apple-darwin9)
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
# echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
# echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -arch ppc -mtune=G4"
# EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
# EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
# echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
# echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -arch ppc -mtune=G4"
# EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
# EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
;;
i686-apple-darwin9)
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
echo "HAVE_DARWIN_OS_ON_INTEL = 1" >> config.mak
# echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
# echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -march=pentium-m -mtune=prescott"
# EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
# EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
SDK_TARGET=10.4
echo "SDK_TARGET = ${SDK_TARGET}" >> config.mak
echo "HAVE_DARWIN_OS_ON_INTEL = 1" >> config.mak
# echo "ENVP = MACOSX_DEPLOYMENT_TARGET=${SDK_TARGET}" >> config.mak
# echo "MACOSX_SDK = /Developer/SDKs/MacOSX10.4u.sdk" >> config.mak
CFLAGS_TUNING=" -march=pentium-m -mtune=prescott"
# EXTRA_CFLAGS=" -D\${ENVP} -isysroot \${MACOSX_SDK} -mmacosx-version-min=\${SDK_TARGET}"
# EXTRA_LDFLAGS=" -isysroot \${MACOSX_SDK} -Wl,-syslibroot,\${MACOSX_SDK}"
echo "PATH = /bin:/usr/bin:/usr/local/bin" >> config.mak
cat src/Distributions/darwin.mak >> distro.mak
;;
i586-pc-beos)
if test -f /boot/beos/system/lib/libbind.so; then
......@@ -244,12 +244,12 @@ echo "EXTRA_LDFLAGS = ${EXTRA_LDFLAGS}" >> config.mak
echo "EXTRA_PATH = ${EXTRA_PATH}" >> config.mak
if which curl >/dev/null; then
echo "WGET = curl -L -O" >> config.mak
echo "WGET = curl -L -O" >> config.mak
elif wget --version >/dev/null 2>&1; then
echo "WGET = wget" >> config.mak
echo "WGET = wget" >> config.mak
else
echo "You need at least wget or curl to fetch the packages." >&2
exit 1
echo "You need at least wget or curl to fetch the packages." >&2
exit 1
fi
if test -f /sw/bin/svn; then
......@@ -257,9 +257,9 @@ if test -f /sw/bin/svn; then
elif test -f /usr/local/bin/svn; then
echo "SVN = /usr/local/bin/svn" >> config.mak
elif test -f /usr/bin/svn; then
echo "SVN = /usr/bin/svn" >> config.mak
echo "SVN = /usr/bin/svn" >> config.mak
elif test -f /opt/local/bin/svn; then
echo "SVN = /opt/local/bin/svn" >> config.mak
echo "SVN = /opt/local/bin/svn" >> config.mak
elif svn help >/dev/null 2>&1; then
echo "SVN = svn" >> config.mak
else
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment