Commit afba69f8 authored by Jean-Paul Saman's avatar Jean-Paul Saman

Added --enable-familiar to configure.in, the default is disabled.

parent b636e582
List of vlc plugins
$Id: MODULES,v 1.4 2002/06/02 23:43:38 bozo Exp $
$Id: MODULES,v 1.5 2002/07/22 13:48:13 jpsaman Exp $
* a52_system: input module for A52 decapsulation.
......@@ -43,6 +43,8 @@ $Id: MODULES,v 1.4 2002/06/02 23:43:38 bozo Exp $
* esd: audio output module using the Esound sound daemon.
* familiar: interface for iPaq using the Gtk+ widget set.
* fb: video output module for the Linux framebuffer.
* filter_deinterlace: naive deinterlacing filter.
......
......@@ -35,6 +35,7 @@ PLUGINS_DIR := a52 \
dvd \
dvdread \
esd \
familiar \
fb \
ffmpeg \
mp4 \
......@@ -101,6 +102,7 @@ PLUGINS_TARGETS := a52/a52 \
dvd/dvd \
dvdread/dvdread \
esd/esd \
familiar/familiar \
fb/fb \
ffmpeg/ffmpeg \
mp4/mp4 \
......
......@@ -65,6 +65,7 @@ directx_CFLAGS = @directx_CFLAGS@
dvd_CFLAGS = @dvd_CFLAGS@
dvdread_CFLAGS = @dvdread_CFLAGS@
esd_CFLAGS = @esd_CFLAGS@
familiar_CFLAGS = @familiar_CFLAGS@
ffmpeg_CFLAGS = @ffmpeg_CFLAGS@
glide_CFLAGS = @glide_CFLAGS@
gnome_CFLAGS = @gnome_CFLAGS@
......@@ -99,6 +100,7 @@ dsp_LDFLAGS = @dsp_LDFLAGS@
dvd_LDFLAGS = @dvd_LDFLAGS@
dvdread_LDFLAGS = @dvdread_LDFLAGS@
esd_LDFLAGS = @esd_LDFLAGS@
familiar_LDFLAGS = @familiar_LDFLAGS@
filter_distort_LDFLAGS = @filter_distort_LDFLAGS@
ffmpeg_LDFLAGS = @ffmpeg_LDFLAGS@
mp4_LDFLAGS = @mp4_LDFLAGS@
......
# $Id: STATUS,v 1.1 2002/07/12 21:57:25 massiot Exp $
# $Id: STATUS,v 1.2 2002/07/22 13:48:13 jpsaman Exp $
#
# VLC STATUS
#
......@@ -56,3 +56,6 @@ Christophe Massiot <massiot@via.ecp.fr> :
rewind, better time handling)
ETA : end of 2002
Jean-Paul Saman <jpsaman@wxs.nl> :
- Familiar Linux interface for iPaq
ETA : late summer
This diff is collapsed.
......@@ -1414,6 +1414,50 @@ then
fi
fi
dnl
dnl Familiar module uses Gtk+ library
dnl
AC_ARG_ENABLE(familiar,
[ --enable-familiar Familiar Gtk+ support (default disabled)])
if test "x${enable_familiar}" = "xyes"
then
GTK_PATH="${PATH}"
AC_ARG_WITH(gtk-config-path,
[ --with-gtk-config-path=PATH gtk-config path (default search in \$PATH)],
[ if test "x${with_gtk_config_path}" != "xno"
then
GTK_PATH="${with_gtk_config_path}:${PATH}"
fi ])
# look for gtk-config
AC_PATH_PROG(GTK12_CONFIG, gtk12-config, no, ${GTK_PATH})
GTK_CONFIG=${GTK12_CONFIG}
if test "x${GTK_CONFIG}" = "xno"
then
AC_PATH_PROG(GTK_CONFIG, gtk-config, no, ${GTK_PATH})
fi
if test "x${GTK_CONFIG}" != "xno"
then
if expr 1.2.0 \> `${GTK_CONFIG} --version` >/dev/null
then
AC_MSG_ERROR([Your development package for Gtk+ is too old, you need at least version 1.2.0. Please upgrade and try again. Alternatively you can also configure with --disable-familiar.])
fi
familiar_CFLAGS="${familiar_CFLAGS} `${GTK_CONFIG} --cflags gtk`"
familiar_LDFLAGS="${familiar_LDFLAGS} `${GTK_CONFIG} --libs gtk | sed 's,-rdynamic,,'`"
# now look for the gtk.h header
CPPFLAGS="${save_CPPFLAGS} ${familiar_CFLAGS}"
ac_cv_gtk_headers=yes
AC_CHECK_HEADERS(gtk/gtk.h glib.h gdk/gdk.h, , [
ac_cv_gtk_headers=no
echo "Cannot find gtk development headers."
])
if test "x${ac_cv_gtk_headers}" = "xyes"
then
PLUGINS="${PLUGINS} familiar"
fi
CPPFLAGS="${save_CPPFLAGS}"
fi
fi
dnl
dnl Gnome module
dnl
......@@ -1786,6 +1830,7 @@ AC_SUBST(dvdread_CFLAGS)
AC_SUBST(mpeg_ts_dvbpsi_CFLAGS)
AC_SUBST(directx_CFLAGS)
AC_SUBST(esd_CFLAGS)
AC_SUBST(familiar_CFLAGS)
AC_SUBST(ffmpeg_CFLAGS)
AC_SUBST(glide_CFLAGS)
AC_SUBST(gnome_CFLAGS)
......@@ -1818,6 +1863,7 @@ AC_SUBST(dvd_LDFLAGS)
AC_SUBST(dvdread_LDFLAGS)
AC_SUBST(mpeg_ts_dvbpsi_LDFLAGS)
AC_SUBST(esd_LDFLAGS)
AC_SUBST(familiar_LDFLAGS)
AC_SUBST(filter_distort_LDFLAGS)
AC_SUBST(ffmpeg_LDFLAGS)
AC_SUBST(mp4_LDFLAGS)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment