Commit ad273906 authored by Sam Hocevar's avatar Sam Hocevar

* ./debian/control: changed the section of gnome-vlc and kvlc according to

    new Debian archive sections.
  * ./debian/woody-buildpackage: updated woody-buildpackage so that packages
    say "stable".
parent 5cc09386
vlc (0.5.2-4) unstable; urgency=low
* Changed the section of gnome-vlc and kvlc according to new Debian
archive sections.
* Updated woody-buildpackage so that packages say "stable".
-- Samuel Hocevar <sam@zoy.org> Tue, 1 Apr 2003 18:08:01 +0200
vlc (0.5.2-3) unstable; urgency=low
* Added explicit dependencies on vlc to legacy packages to make linda and
lintian happier.
* Added correct versioned build-dependency on debhelper.
* Updated the autotools helper files in extras/faad.
-- Samuel Hocevar <sam@zoy.org> Tue, 25 Mar 2003 23:21:51 +0100
-- Samuel Hocevar <sam@zoy.org> Wed, 26 Mar 2003 02:50:34 +0100
vlc (0.5.2-2) unstable; urgency=low
......
......@@ -28,7 +28,7 @@ Description: development files for VLC
for VLC, or standalone applications that use VLC features.
Package: gnome-vlc
Section: graphics
Section: gnome
Architecture: any
Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
Recommends: vlc-plugin-esd
......@@ -40,6 +40,7 @@ Description: GNOME frontend for VLC
it, use the `--intf gnome' flag or run the `gnome-vlc' program.
Package: vlc-gnome
Section: gnome
Architecture: any
Depends: vlc, gnome-vlc
Description: legacy package that you should remove
......@@ -179,6 +180,7 @@ Description: a multimedia plugin for Mozilla based on VLC
window. There is also support for fullscreen display and javascript control.
Package: kvlc
Section: kde
Architecture: any
Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
Recommends: vlc-plugin-arts
......
#! /bin/sh
# $Id: woody-buildpackage,v 1.11 2003/03/25 22:55:32 sam Exp $
# $Id: woody-buildpackage,v 1.12 2003/04/01 16:13:39 sam Exp $
# Build VLC for a Woody Debian system
if test ! -d debian
......@@ -11,6 +11,7 @@ fi
# changelog: replace (1.2.3-4) with (1.2.3-0woody.4)
sed -e 's/^vlc (\([^)]*\)-\([^-)]*\))/vlc (\1-0woody.\2)/' \
-e 's/ unstable; / stable; /' \
< debian/changelog > debian/changelog.woody
# control: replace liba52-*-dev with a52dec-dev (>=0.7.3)
......@@ -24,6 +25,8 @@ sed -e 's/^vlc (\([^)]*\)-\([^-)]*\))/vlc (\1-0woody.\2)/' \
# libflac-dev
# libidl0 (workaround for mozilla-dev's bad deps)
# libglib2.0-0 (workaround for mozilla-dev's bad deps)
# change Section: gnome with Section: graphics
# Section: kde with Section: kde
sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
-e 's/libdv[0-9]*-dev/libdv-dev/' \
-e 's/kdelibs[0-9]*-dev/kdelibs-dev/' \
......@@ -37,6 +40,8 @@ sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
-e 's/, libflac-dev[^,]*//' \
-e 's/, libidl0[^,]*//' \
-e 's/, libglib2.0-0[^,]*//' \
-e 's/Section: gnome/Section: graphics/' \
-e 's/Section: kde/Section: graphics/' \
< debian/control > debian/control.woody
# rules: remove wxwindows stuff
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment