Commit 9d85b9da authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont

Some build systems clean up. Now require automake 1.7

Automake 1.5 and 1.6 both suck, and 1.7 is almost four years old, so there is really no excuse for not using a decent version. Besides, there seems to some problems while building the loader with old Automake versions.
parent bb3c43d2
......@@ -47,10 +47,6 @@ endif
# Tell aclocal to use -I m4. Wonder if it really works.
ACLOCAL_AMFLAGS = -I m4
# XXX: these flags could be set in configure.ac, but we set them here
# because old versions of automake don't support them in configure.ac.
AUTOMAKE_OPTIONS = dist-bzip2
###############################################################################
# MacOS X project
###############################################################################
......
......@@ -52,7 +52,7 @@ fi
# Check for automake
amvers="no"
for v in "-1.9" "19" "-1.8" "18" "-1.7" "17" "-1.6" "16" "-1.5" "15"; do
for v in "-1.9" "19" "-1.8" "18" "-1.7" "17"; do
if automake${v} --version >/dev/null 2>&1; then
amsuff="${v}"
amvers="${v}"
......@@ -66,15 +66,9 @@ if test "${amvers}" = "no" && automake --version > /dev/null 2>&1; then
fi
case "${amvers}" in
-1.6|16|1.6|1.6.0*|1.6.1*)
AUTOMAKESUCKS=yes
;;
-1.5|15|1.5|1.5.*)
INSTALLSUCKS=yes
;;
no|1.[01234]|1.[01234].*|1[01234])
no|1.[0123456]|1.[0123456].*|1[0123456])
set +x
echo "$0: you need automake version 1.5 or later"
echo "$0: you need automake version 1.7 or later"
exit 1
;;
esac
......@@ -467,7 +461,7 @@ ${autopoint} -f
${aclocal} ${ACLOCAL_ARGS}
${autoconf}
${autoheader}
${automake} --add-missing --copy
${automake} --add-missing --copy -Wall
##
## files which need to be regenerated
......@@ -503,25 +497,3 @@ reliable.
EOF
fi
if [ "$AUTOMAKESUCKS" = "yes" ]; then
cat << EOF
=============================================================
IMPORTANT NOTE: your version of automake has a bug which will
prevent proper plugin compilation. Either compile VLC with
the --disable-plugins flag, or use a version of automake newer
than 1.6.1 (1.6.2 is OK, and so are the 1.5 series).
EOF
fi
if [ "$INSTALLSUCKS" = "yes" ]; then
cat << EOF
=============================================================
IMPORTANT NOTE: your version of automake has a bug which will
prevent proper installation. Do not use "make install" with this
version of automake, or use a version of automake newer than 1.5
(such as 1.6 or 1.7).
EOF
fi
......@@ -14,9 +14,7 @@ AC_CONFIG_SRCDIR(src/libvlc.c)
AC_CONFIG_AUX_DIR(autotools)
AC_CANONICAL_SYSTEM
dnl XXX: we don't put any flags here, because automake 1.5 doesn't support
dnl them. And we need the comma otherwize automake will choke on it.
AM_INIT_AUTOMAKE(vlc,0.8.6-svn)
AM_INIT_AUTOMAKE([1.7 check-news dist-bzip2])
AM_CONFIG_HEADER(config.h)
dnl Too many people are not aware of maintainer mode:
......@@ -310,7 +308,7 @@ AM_GNU_GETTEXT_VERSION(0.11.5)
AM_GNU_GETTEXT
if test "${nls_cv_force_use_gnu_gettext}" = "yes"; then
AC_DEFINE(HAVE_INCLUDED_GETTEXT, 1, Define if we use the local libintl)
INCLUDES="${INCLUDES} -I\$(top_builddir)/intl"
AM_CPPFLAGS="${AM_CPPFLAGS} -I\$(top_builddir)/intl"
AS_IF([test "${enable_libtool}" != "no"], [
INCLUDED_LIBINTL="${LTLIBINTL}"
],[
......@@ -5447,7 +5445,7 @@ AC_SUBST(MOZILLA_SDK_PATH)
AC_SUBST(XPIDL)
AC_SUBST(XPIDL_INCL)
AC_SUBST(LIBEXT)
AC_SUBST(INCLUDES)
AC_SUBST(AM_CPPFLAGS)
AC_SUBST(ALL_LINGUAS)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
AC_SUBST(FILE_LIBVLC_DLL)
......
......@@ -12,7 +12,7 @@
AUTOMAKE_OPTIONS = subdir-objects
TOUI = ui/input_stats
UIH := $(TOUI:%=%.h)
UIH = $(TOUI:%=%.h)
TOMOC = main_interface \
dialogs_provider \
......@@ -24,7 +24,7 @@ TOMOC = main_interface \
components/preferences_widgets \
components/preferences \
util/input_slider
MOCCPP := $(TOMOC:%=%.moc.cpp)
MOCCPP = $(TOMOC:%=%.moc.cpp)
nodist_SOURCES_qt4 = \
main_interface.moc.cpp \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment