Commit 9bfeef47 authored by Sam Hocevar's avatar Sam Hocevar
Browse files

* ./debian/control: bumped up standards version to 0.5.9.0.

  * ./debian/control: added build-dependencies on libidl0 and libglib2.0-0 to
    work around mozilla-dev's currently broken dependencies.
  * ./debian/control: we now link against libdvdread3 instead of libdvdread2.
  * ./debian/control: we now depend on the latest libdvdplay0-dev to avoid
    linking against both libdvdread2 and libdvdread3.
parent 92960f7e
vlc (0.5.2-2) unstable; urgency=low
* Bumped up standards version to 0.5.9.0.
* Added build-dependencies on libidl0 and libglib2.0-0 to work around
mozilla-dev's currently broken dependencies.
* We now link against libdvdread3 instead of libdvdread2.
-- Samuel Hocevar <sam@zoy.org> Tue, 25 Mar 2003 23:21:51 +0100
vlc (0.5.2-1) unstable; urgency=low
* New upstream release.
......
......@@ -2,8 +2,8 @@ Source: vlc
Section: graphics
Priority: optional
Maintainer: Samuel Hocevar <sam@zoy.org>
Build-Depends: debhelper (>=2.2.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev, libdvdread2-dev, libslp-dev, libflac-dev (>=1.1.0)
Standards-Version: 3.5.6
Build-Depends: debhelper (>=2.2.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0)
Standards-Version: 3.5.9.0
Package: vlc
Section: graphics
......
#! /bin/sh
# $Id: woody-buildpackage,v 1.10 2003/03/11 22:44:48 sam Exp $
# $Id: woody-buildpackage,v 1.11 2003/03/25 22:55:32 sam Exp $
# Build VLC for a Woody Debian system
if test ! -d debian
......@@ -18,17 +18,25 @@ sed -e 's/^vlc (\([^)]*\)-\([^-)]*\))/vlc (\1-0woody.\2)/' \
# kdelibs4-dev with kdelibs-dev
# libqt3-mt-dev libqt3-compat-headers with libqt-dev
# libarts1-dev with libarts-dev
# libdvdread3-dev with libdvdread2-dev
# libdvdplay0-dev (>=1.0.1-2) with libdvdplay0-dev
# remove libwxgtk2.4-dev
# libflac-dev
# libidl0 (workaround for mozilla-dev's bad deps)
# libglib2.0-0 (workaround for mozilla-dev's bad deps)
sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
-e 's/libdv[0-9]*-dev/libdv-dev/' \
-e 's/kdelibs[0-9]*-dev/kdelibs-dev/' \
-e 's/libqt[0-9]*-mt-dev/libqt-dev/' \
-e 's/, libqt[0-9]*-compat-headers[^,]*//' \
-e 's/libarts[0-9]*-dev/libarts-dev/' \
-e 's/libdvdread[0-9]*-dev/libdvdread2-dev/' \
-e 's/, libdvdplay0-dev[^,]*/, libdvdplay0-dev/' \
-e 's/, libwx[^,]*//' \
-e '/Package: wxvlc/,/^ *$/d' \
-e 's/, libflac-dev[^,]*//' \
-e 's/, libidl0[^,]*//' \
-e 's/, libglib2.0-0[^,]*//' \
< debian/control > debian/control.woody
# rules: remove wxwindows stuff
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment