Commit 999e1c36 authored by David Flynn's avatar David Flynn Committed by Rémi Denis-Courmont

Disable glibc runtime check if configure passed due to disable-{nls, mozilla}

Signed-off-by: default avatarDavid Flynn <davidf@rd.bbc.co.uk>
Signed-off-by: Rémi Denis-Courmont's avatarRémi Denis-Courmont <remi@remlab.net>
parent dd3a05a9
......@@ -559,6 +559,8 @@ AC_PREPROC_IFELSE([
work-around for this. Check with your distribution vendor on how to update the
glibc run-time. Alternatively, build with --disable-nls --disable-mozilla and
be sure to not use LibVLC from other applications/wrappers.])
], [
AC_DEFINE(DISABLE_BUGGY_GLIBC_CHECK, 1, [Disables runtime check for buggy glibc.])
])
])
......
......@@ -90,7 +90,9 @@ void system_Init (libvlc_int_t *libvlc, int *argc, const char *argv[])
fputs ("LibVLC has detected an unusable buggy GNU/libc version.\n"
"Please update to version 2.8 or newer.\n", stderr);
fflush (stderr);
#ifndef DISABLE_BUGGY_GLIBC_CHECK
abort ();
#endif
}
#endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment