Commit 9419d728 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

fluidsynth: require version 1.1.x

1.0.x is full of memory leaks and race conditions, and lacks features.
parent 8b970ddc
......@@ -2830,7 +2830,7 @@ fi
dnl
dnl libfluidsynth (MIDI synthetizer) plugin
dnl
PKG_ENABLE_MODULES_VLC([FLUIDSYNTH], [], [fluidsynth], [MIDI synthetiser with libfluidsynth], [auto])
PKG_ENABLE_MODULES_VLC([FLUIDSYNTH], [], [fluidsynth >= 1.1.0], [MIDI synthetiser with libfluidsynth], [auto])
dnl
dnl Teletext Modules
......
......@@ -45,14 +45,6 @@
#include <fluidsynth.h>
#if (FLUIDSYNTH_VERSION_MAJOR < 1) \
|| (FLUIDSYNTH_VERSION_MAJOR == 1 && FLUIDSYNTH_VERSION_MINOR < 1)
# define FLUID_FAILED (-1)
# define fluid_synth_sysex(synth, ptr, len, d, e, f, g) (FLUID_FAILED)
# define fluid_synth_system_reset(synth) (FLUID_FAILED)
# define fluid_synth_channel_pressure(synth, channel, p) (FLUID_FAILED)
#endif
#define SOUNDFONT_TEXT N_("Sound fonts")
#define SOUNDFONT_LONGTEXT N_( \
"A sound fonts file is required for software synthesis." )
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment