Commit 9368908a authored by Konstantin Pavlov's avatar Konstantin Pavlov

Explicitely include libavutil/mem.h where needed.

libavutil.h doesnt include common.h since lavu 51.39.
parent 0625a95d
......@@ -36,6 +36,7 @@
/* ffmpeg header */
#include <libavcodec/avcodec.h>
#include <libavutil/mem.h>
#if LIBAVUTIL_VERSION_INT >= ((50<<16)+(38<<8)+0)
# include "libavutil/audioconvert.h"
......
......@@ -35,6 +35,7 @@
/* ffmpeg header */
#include <libavcodec/avcodec.h>
#include <libavutil/mem.h>
#ifdef HAVE_AVCODEC_VAAPI
# include <libavcodec/vaapi.h>
#endif
......
......@@ -45,6 +45,7 @@
/* ffmpeg header */
#include <libavcodec/avcodec.h>
#include <libavutil/mem.h>
#ifdef HAVE_AVCODEC_VAAPI
# include <libavcodec/vaapi.h>
#endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment