Commit 8d37aa9a authored by Konstantin Pavlov's avatar Konstantin Pavlov

contribs: build libbluray with libxml2.

Required for metadata support.
parent 87e18497
......@@ -6,5 +6,5 @@ diff -ru libbluray/src/libbluray.pc.in libbluray2/src/libbluray.pc.in
Description: library supporting Blu-ray playback
Version: @PACKAGE_VERSION@
-Libs: -L${libdir} -lbluray
+Libs: -L${libdir} -lbluray @DLOPEN_LDFLAGS@
+Libs: -L${libdir} -lbluray @DLOPEN_LDFLAGS@ @LIBXML2_LIBS@
Cflags: -I${includedir}
......@@ -7,6 +7,8 @@ ifeq ($(call need_pkg,"libbluray >= 0.2.1"),)
PKGS_FOUND += bluray
endif
DEPS_bluray = libxml2 $(DEPS_libxml2)
BLURAY_VERSION := 0.2.1
BLURAY_URL := http://ftp.videolan.org/pub/videolan/libbluray/$(BLURAY_VERSION)/libbluray-$(BLURAY_VERSION).tar.bz2
......@@ -22,6 +24,6 @@ bluray: libbluray-$(BLURAY_VERSION).tar.bz2 .sum-bluray
.bluray: bluray
cd $< && ./bootstrap
cd $< && $(HOSTVARS) ./configure --disable-examples --disable-debug --disable-libxml2 $(HOSTCONF)
cd $< && $(HOSTVARS) ./configure --disable-examples --disable-debug --enable-libxml2 $(HOSTCONF)
cd $< && $(MAKE) install
touch $@
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment