Commit 774a2977 authored by Felix Paul Kühne's avatar Felix Paul Kühne
Browse files

* patch libtwolame and re-enable x264 as it was fixed upstream. all contribs...

* patch libtwolame and re-enable x264 as it was fixed upstream. all contribs are save for future darwin releases now. this commit deprecates all osx releases < 10.4 and the usage of GCC3 on Darwin. bootstrap will need further tweaking once 'gcc -dumpmachine' is updated to Darwin 9.
parent fc1f0e4f
......@@ -57,9 +57,9 @@ fi
case $HOST in
ppc-darwin)
# Mac OS X < 10.4
echo "HAVE_DARWIN_OS = 1" >> config.mak
EXTRA_CPPFLAGS=" -no-cpp-precomp"
echo "PATH = /bin:/usr/bin" >> config.mak
echo "Your version of Mac OS X is too old!" >&2
echo "Compiling VLC requires 10.4.x or later" >&2
exit 1
;;
powerpc-apple-darwin8)
# Mac OS X 10.4
......@@ -134,10 +134,6 @@ case $HOST in
;;
esac
if test `uname -r` = "9.0.0d5"; then
echo "HAVE_FUTURE_DARWIN_OS = 1" >> config.mak
fi
echo "BUILD = $BUILD" >> config.mak
echo "HOST = $HOST" >> config.mak
......
......@@ -144,23 +144,13 @@ endif
# ***************************************************************************
ifdef HAVE_DARWIN_OS
ifdef HAVE_FUTURE_DARWIN_OS
all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.a52 .mpeg2 .id3tag .mad .ogg .vorbis .vorbisenc .theora \
.FLAC .speex .shout .faad .faac .lame .ebml .matroska .ffmpeg \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .cddb .cdio .vcdimager \
.SDL_image .glib .libidl .gecko .mpcdec .dirac_encoder .dirac_decoder \
.libdca .tag .goom2k4 .aclocal
else
all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.a52 .mpeg2 .id3tag .mad .ogg .vorbis .vorbisenc .theora \
.FLAC .speex .shout .faad .faac .lame .twolame .ebml .matroska .ffmpeg \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .cddb .cdio .vcdimager \
.SDL_image .glib .libidl .gecko .mpcdec .dirac_encoder .dirac_decoder \
.libdca .tag .x264 .goom2k4 .aclocal
endif
all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.a52 .mpeg2 .id3tag .mad .ogg .vorbis .vorbisenc .theora \
.FLAC .speex .shout .faad .faac .lame .twolame .ebml .matroska .ffmpeg \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .cddb .cdio .vcdimager \
.SDL_image .glib .libidl .gecko .mpcdec .dirac_encoder .dirac_decoder \
.libdca .tag .x264 .goom2k4 .aclocal
# .expat .clinkcc don't work with SDK yet
# .glib .libidl .gecko are required to build the mozilla plugin
# .mozilla will build an entire mozilla. it can be used if we need to create a new .gecko package
......@@ -1458,6 +1448,9 @@ twolame: twolame-$(TWOLAME_VERSION).tar.gz
ifdef HAVE_BEOS
patch -p0 < Patches/twolame-BeOS.patch
endif
ifdef HAVE_DARWIN_OS
patch -p0 < Patches/twolame-osx.patch
endif
.twolame: twolame
(cd twolame; $(HOSTCC) ./configure $(HOSTCONF) --prefix=$(PREFIX) && make && make install)
......
--- twolame.orig/libtwolame/bitbuffer.c 2006-05-23 19:27:49.000000000 +0200
+++ twolame/libtwolame/bitbuffer.c 2007-01-06 17:04:49.000000000 +0100
@@ -73,7 +73,7 @@
}
/*write N bits into the bit stream */
-inline void buffer_putbits (bit_stream * bs, unsigned int val, int N)
+void buffer_putbits (bit_stream * bs, unsigned int val, int N)
{
static const int putmask[9] = { 0x0, 0x1, 0x3, 0x7, 0xf, 0x1f, 0x3f, 0x7f, 0xff };
register int j = N;
--- twolame.orig/libtwolame/bitbuffer.h 2006-05-23 19:27:49.000000000 +0200
+++ twolame/libtwolame/bitbuffer.h 2007-01-06 17:04:56.000000000 +0100
@@ -40,7 +40,7 @@
void buffer_deinit( bit_stream ** bs );
void buffer_put1bit (bit_stream *, int);
-inline void buffer_putbits (bit_stream *, unsigned int, int);
+void buffer_putbits (bit_stream *, unsigned int, int);
unsigned long buffer_sstell (bit_stream *);
#endif
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment