Commit 68d81870 authored by Konstantin Pavlov's avatar Konstantin Pavlov

Fix liblua5.1 detection on non-debian system (e.g. mine) that doesn't have...

Fix liblua5.1 detection on non-debian system (e.g. mine) that doesn't have lua5.1.pc but do have lua.pc.
Check for lua >= 5.1.
parent 70492e68
...@@ -1538,12 +1538,21 @@ AC_ARG_ENABLE(luaplaylist, ...@@ -1538,12 +1538,21 @@ AC_ARG_ENABLE(luaplaylist,
if test "${enable_lua}" != "no" if test "${enable_lua}" != "no"
then then
PKG_CHECK_MODULES(LUA, lua5.1, PKG_CHECK_MODULES(LUA, lua5.1,
[ AC_DEFINE(HAVE_LUA, [], [Define if you have the lua library]) [ have_lua=yes ],
VLC_ADD_PLUGINS([luaplaylist]) [
VLC_ADD_LDFLAGS([luaplaylist],[$LUA_LIBS]) AC_MSG_WARN([lua5.1 not found, trying lua >= 5.1 instead])
VLC_ADD_CFLAGS([luaplaylist],[$LUA_CFLAGS]) PKG_CHECK_MODULES(LUA, lua >= 5.1,
], [ have_lua=yes ],
[AC_MSG_WARN(lua 5.0 not found)]) [
AC_MSG_WARN([lua >= 5.1 not found!])
])
])
if test "x${have_lua}" = "xyes"; then
AC_DEFINE(HAVE_LUA, [], [Define if you have the lua library])
VLC_ADD_PLUGINS([luaplaylist])
VLC_ADD_LDFLAGS([luaplaylist],[$LUA_LIBS])
VLC_ADD_CFLAGS([luaplaylist],[$LUA_CFLAGS])
fi
fi fi
dnl dnl
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment