Commit 6810a85e authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont

Revert lame revert from [16628].

Provide trivial work-around for users of obsolete autoconf
parent 9360ead0
...@@ -48,6 +48,20 @@ if test -d extras/contrib/bin; then ...@@ -48,6 +48,20 @@ if test -d extras/contrib/bin; then
fi fi
fi fi
# Check for autoconf
rm -f m4/autoconf260.m4
case "$(autoconf --version|head -1)" in
*2.5[012345678]*)
echo "Hey, your autoconf is quite old. Update it." >&2
exit 1
;;
*2.59*)
echo "Enabling provisional autoconf 2.59 work-around. Update autoconf ASAP."
cp -f extras/m4/autoconf260.m4 m4/
;;
esac
# Check for automake # Check for automake
amvers="no" amvers="no"
for v in "-1.9" "19" "-1.8" "18" "-1.7" "17"; do for v in "-1.9" "19" "-1.8" "18" "-1.7" "17"; do
......
...@@ -37,8 +37,8 @@ VLC_SAVE_FLAGS ...@@ -37,8 +37,8 @@ VLC_SAVE_FLAGS
dnl dnl
dnl Check for tools dnl Check for tools
dnl dnl
AC_PROG_CC_C99
AM_PROG_CC_C_O AM_PROG_CC_C_O
AC_PROG_CPP
AC_PROG_CXX AC_PROG_CXX
eval "${CXX} --version" >/dev/null 2>&1 || CXX="" eval "${CXX} --version" >/dev/null 2>&1 || CXX=""
if test "${CXX}" != ""; then if test "${CXX}" != ""; then
......
# Replacements for autoconf 2.59 and older
# Please make official source tarballs with recent autoconf only.
AC_DEFUN([AC_PROG_CC_C00],
[ AC_REQUIRE([AC_PROG_CC])dnl
CC="$CC -std=c99"
])
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment