Commit 5fc41d70 authored by Sam Hocevar's avatar Sam Hocevar

* updated Debian build files

parent 4bd7c74d
vlc (0.8.4-svn20050810-2) unstable; urgency=low
* debian/control:
+ Build-depend on libarts1-dev (>= 1.4.2-1).
+ Build-depend on a newer version of libavcodec.
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Tue, 16 Aug 2005 17:36:21 +0200
vlc (0.8.4-svn20050810-1) unstable; urgency=low
* New SVN snapshot.
......@@ -14,8 +22,8 @@ vlc (0.8.4-svn20050810-1) unstable; urgency=low
+ Build-depend on libwxgtk2.4-dev (>= 2.4.4).
+ Build-depend on libdvbpsi4-dev instead of libdvbpsi3-dev.
* Build-depend on libsdl1.2-dev (>= 1.2.7+1.2.8cvs20041007-5.3).
+ Build-depend on a newer version of libmatroska-dev because of the C++
transition.
+ Build-depend on a newer version of libmatroska-dev and mozilla-dev
because of the C++ transition.
+ Build-depend on libsvga1-dev instead of svgalib1-dev.
* This snapshot no longer uses tune=opteron on amd64 (Closes: #316161).
* The SVN version adds support for Freebox users (Closes: #317035).
......@@ -23,7 +31,7 @@ vlc (0.8.4-svn20050810-1) unstable; urgency=low
* mozilla/support/npunix.c: fixed undeclared NPP_GetJavaClass
(Closes: #317067).
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Wed, 13 Jul 2005 21:54:09 +0200
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Wed, 10 Aug 2005 16:18:37 +0200
vlc (0.8.2-1) unstable; urgency=low
......
......@@ -2,7 +2,7 @@ Source: vlc
Section: graphics
Priority: optional
Maintainer: Sam Hocevar (Debian packages) <sam+deb@zoy.org>
Build-Depends: debhelper (>= 4.0), dpatch, gettext, libx11-dev, libxext-dev, libxt-dev, libxv-dev, xlibs-static-pic, libggi2-dev, libglide2-dev [i386], libesd0-dev, libaudiofile-dev, libsdl1.2-dev (>= 1.2.7+1.2.8cvs20041007-5.3), libasound2-dev (>= 0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, libaa1-dev, libdvbpsi4-dev, mozilla-dev, libidl0, libglib2.0-0, libxosd-dev (>= 2.2.4-1.3), libsvga1-dev [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev (>= 2.4.2.6) | libwxgtk2.6-dev, libdvdread3-dev, libflac-dev (>= 1.1.1-5), libimlib2-dev, libmatroska-dev (>= 0.7.7), libfreetype6-dev, linux-kernel-headers (>= 2.5.999-test7-bk-7), libcaca-dev (>= 0.9), liblivemedia-dev (>= 2004.11.11a-1), libmpeg2-4-dev, zlib1g-dev, libdts-dev, libfribidi-dev, libcdio-dev, libxml2-dev, libid3tag0-dev, libtheora-dev, jam, nasm, libmodplug-dev, libhal-dev, libtar-dev, libdvdnav-dev, libgnutls11-dev, libavcodec-dev (>= 0.cvs20050626-1), libavformat-dev (>= 0.cvs20050626-1), libpostproc-dev (>= 0.cvs20050626-1), libncurses5-dev, libpng12-dev, xlibmesa-gl-dev
Build-Depends: debhelper (>= 4.0), dpatch, gettext, libx11-dev, libxext-dev, libxt-dev, libxv-dev, xlibs-static-pic, libggi2-dev, libglide2-dev [i386], libesd0-dev, libaudiofile-dev, libsdl1.2-dev (>= 1.2.7+1.2.8cvs20041007-5.3), libasound2-dev (>= 0.9.0beta10a), libarts1-dev (>= 1.4.2-1), libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, libaa1-dev, libdvbpsi4-dev, mozilla-dev (>= 2:1.7.10-1), libidl0, libglib2.0-0, libxosd-dev (>= 2.2.4-1.3), libsvga1-dev [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev (>= 2.4.2.6) | libwxgtk2.6-dev, libdvdread3-dev, libflac-dev (>= 1.1.1-5), libimlib2-dev, libmatroska-dev (>= 0.7.7), libfreetype6-dev, linux-kernel-headers (>= 2.5.999-test7-bk-7), libcaca-dev (>= 0.9), liblivemedia-dev (>= 2004.11.11a-1), libmpeg2-4-dev, zlib1g-dev, libdts-dev, libfribidi-dev, libcdio-dev, libxml2-dev, libid3tag0-dev, libtheora-dev, jam, nasm, libmodplug-dev, libhal-dev, libtar-dev, libdvdnav-dev, libgnutls11-dev, libavcodec-dev (>= 0.cvs20050811-1), libavformat-dev (>= 0.cvs20050811-1), libpostproc-dev (>= 0.cvs20050811-1), libncurses5-dev, libpng12-dev, xlibmesa-gl-dev
Standards-Version: 3.6.2.1
Package: vlc
......
......@@ -171,6 +171,9 @@ clean: unpatch
cd extras/faad2 && $(MAKE) distclean; \
fi
# Clean zsh completion stuff
rm -f extras/zsh
# Removed ugly cruft
rm -f src/misc/modules_builtin.h
rm -f mozilla/vlcintf.xpt mozilla/vlcintf.h
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment