Commit 5aa35524 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

Require libxml2 < 2.7

Thread initialization has changed in 2.7, such that VLC and Qt4 cannot
both use libxml2. While this maximum version requirement is bound to
frustrate Linux/BSD users, we cannot fix this within VLC. Falling back
to xtag is not quite as bad as crashing.
parent 620ea88c
......@@ -4311,13 +4311,13 @@ dnl
AC_ARG_ENABLE(libxml2,
[ --enable-libxml2 libxml2 support (default enabled)])
AS_IF([test "${enable_libxml2}" != "no"], [
PKG_CHECK_MODULES([XML2], [libxml-2.0 >= 2.5], [
PKG_CHECK_MODULES([XML2], [libxml-2.0 >= 2.5 libxml-2.0 < 2.7], [
VLC_ADD_CPPFLAGS([xml],[${XML2_CFLAGS}])
VLC_ADD_LIBS([xml],[${XML2_LIBS}])
VLC_ADD_PLUGIN([xml])
], [
AS_IF([test "x${enable_xml2}" != "x"], [
AC_MSG_ERROR([Could not find libxml2])
AC_MSG_ERROR([Could not find libxml version 2.5 or 2.6])
])
])
])
......
......@@ -35,6 +35,10 @@
#include <libxml/xmlreader.h>
#include <libxml/catalog.h>
#if !defined (LIBXML_VERSION) || (LIBXML_VERSION > 20700)
# error Stale config.cache detected. Erase it and re-run configure.
#endif
/*****************************************************************************
* Module descriptor
*****************************************************************************/
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment