Commit 58e68e2f authored by Steve Lhomme's avatar Steve Lhomme

contrib: gmp: don't use the cross compiler to test the build compiler

To build native tools it tries to use $CC when cross-compilation is detected,
which is most likely wrong.

This patch already exists in nettle that contains a version of gmp. But it's
not in the upstream version of gmp.
parent 424e8991
......@@ -35,6 +35,8 @@ gmp: gmp-$(GMP_VERSION).tar.bz2 .sum-gmp
$(APPLY) $(SRC)/gmp/ppc64.patch
$(APPLY) $(SRC)/gmp/win-arm64.patch
$(APPLY) $(SRC)/gmp/gmp-fix-asm-detection.patch
# do not try the cross compiler to detect the build compiler
cd $(UNPACK_DIR) && sed -i.orig 's/"$$CC" "$$CC $$CFLAGS $$CPPFLAGS" cc gcc c89 c99/cc gcc c89 c99/' acinclude.m4
$(MOVE)
# GMP requires either GPLv2 or LGPLv3
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment