Commit 5824aabb authored by Ramiro Polla's avatar Ramiro Polla Committed by Jean-Baptiste Kempf
Browse files

Use pkg-config to check for libmodplug, and check for version >= 0.8, which is...


Use pkg-config to check for libmodplug, and check for version >= 0.8, which is needed for some functions like ModPlug_NumSamples(), ModPlug_GetMessage(), ModPlug_NumInstruments(), etc...
Signed-off-by: Jean-Baptiste Kempf's avatarJean-Baptiste Kempf <jb@videolan.org>
parent 36a25fbe
......@@ -2756,10 +2756,11 @@ then
AC_MSG_ERROR([cannot find ${real_mod_tree}/src/.libs/libmodplug.a, make sure you compiled mod in ${with_mod_tree}])
fi
else
AC_CHECK_HEADERS(libmodplug/modplug.h, [
VLC_ADD_PLUGIN([mod])
VLC_ADD_CXXFLAGS([mod],[])
VLC_ADD_LIBS([mod],[-lmodplug -lstdc++])])
PKG_CHECK_MODULES(LIBMODPLUG, libmodplug >= 0.8,
[ VLC_ADD_PLUGIN([mod])
VLC_ADD_CXXFLAGS([mod],[$LIBMODPLUG_CFLAGS])
VLC_ADD_LIBS([mod],[$LIBMODPLUG_LIBS])
],[AC_MSG_WARN([libmodplug not found!])])
fi
fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment