Commit 415af2ad authored by Sam Hocevar's avatar Sam Hocevar

* ./bootstrap: added a check for automake bug #326. No easy workaround is

    really possible other than patching/upgrading automake. This happens for
    automake 1.6.0 and automake 1.6.1.
parent 31c31586
#! /bin/sh
## bootstrap file for vlc, the VideoLAN Client
## $Id: bootstrap,v 1.15 2002/10/02 12:59:59 sam Exp $
## $Id: bootstrap,v 1.16 2002/10/02 16:02:43 sam Exp $
##
## Authors: Samuel Hocevar <sam@zoy.org>
......@@ -37,6 +37,7 @@ then
fi
PERLSUCKS=no
AUTOMAKESUCKS=no
##
## Generate the modules makefile, by parsing modules/**/Modules.am
......@@ -92,8 +93,13 @@ EOF
AM_CONDITIONAL(${mod}_plugin, test x\$${mod}_plugin = xyes)
AM_CONDITIONAL(${mod}_builtin, test x\$${mod}_builtin = xyes)
EOF
# L_ is for LIBRARIES_, D_ for DATA_, B_ for BUILT_SOURCES_, F_ for LDFLAGS_
# _p is for _plugin, _b is for _builtin
# Generation of Modules.am
# ~~~~~~~~~~~~~~~~~~~~~~~~
# - L_ is for LIBRARIES_, D_ for DATA_, B_ for BUILT_SOURCES_, F_ for LDFLAGS_,
# S_ for SOURCES_, _p is for _plugin, _b is for _builtin. This is to reduce
# the resulting file size.
# - *_CFLAGS, *_CXXFLAGS etc. include *_CPPFLAGS because per-object CPPFLAGS
# does not seem to work properly with any automake version I tested.
cat >> Modules.am << EOF
# The ${mod} plugin
......@@ -195,6 +201,9 @@ amvers="none"
if automake-1.6 --version >/dev/null 2>&1
then
amvers="-1.6"
if expr "`automake-1.6 --version | sed -e '1s/[^0-9]*//' -e q`" "<=" "1.6.1" > /dev/null 2>&1
then AUTOMAKESUCKS=yes
fi
else
if automake-1.5 --version >/dev/null 2>&1
then
......@@ -202,7 +211,11 @@ else
else
if automake --version > /dev/null 2>&1
then
amvers=`automake --version | sed -e '1s/[^0-9]*//' -e q`
amvers=`echo $amvers | sed -e '1s/[^0-9]*//' -e q`
case $amvers in
1.6|1.6.0|1.6.1)
AUTOMAKESUCKS=yes ;;
esac
if expr "$amvers" "<" "1.5" > /dev/null 2>&1
then amvers="none"
......@@ -325,6 +338,19 @@ case "$GETTEXT" in
;;
esac
case "$AUTOMAKESUCKS" in
no)
;;
yes)
echo ""
echo "============================================================="
echo "IMPORTANT NOTE: your version of automake has a bug which will"
echo "prevent proper plugin compilation. Either compile VLC with"
echo "the --disable-plugins flag, or use a version of automake newer"
echo "than 1.6.1 (1.6.2 is OK, and so are the 1.5 series)."
;;
esac
case "$SEDSUCKS" in
no)
;;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment