Commit 23f9cfa6 authored by Sam Hocevar's avatar Sam Hocevar
Browse files

* Updated Debian build files for a future upload.

parent 629d9dda
vlc (UNRELEASED) experimental; urgency=low
* Experimental build.
* debian/control:
+ Build-depend on libwxgtk2.6-dev instead of libwxgtk2.4-dev.
+ Build-depend on libdvbpsi4-dev instead of libdvbpsi3-dev.
+ Build-depend on a newer version of libmatroska-dev because of the C++
transition.
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Fri, 15 Jul 2005 03:22:46 +0300
vlc (0.8.2-1) unstable; urgency=low
* New upstream release.
* This version fixes the random playlist parsing (Closes: #308375), encodes
non-ASCII characters in RTSP requests (Closes: #279735) and fixes an issue
with large files (Closes: #306110).
* debian/control:
+ Set policy to 3.6.2.1.
+ Build-depend on libpng12-dev, xlibmesa-gl-dev.
+ Build-depend on a more recent ffmpeg library set, to fix nasty visual
artifacts with post-processing (Closes: #300220).
+ mozilla-plugin-vlc recommends mozilla-firefox in addition to
mozilla-browser (Closes: #308723).
+ Now that sarge is out, removed legacy packages that disappeared in woody.
* debian/rules:
+ Activated PNG output support.
+ Activated GLX output support.
* The NEWS file documents the changed behaviour for SAP (Closes: #303262).
* Minor typo fixed in the manpage (Closes: #300339).
* po/de.po: merged corrections from Jens Seidel (Closes: #313890).
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Sun, 26 Jun 2005 16:28:19 +0200
vlc (0.8.1.svn20050314-1) unstable; urgency=low
* More recent SVN snapshot.
......
......@@ -2,8 +2,8 @@ Source: vlc
Section: graphics
Priority: optional
Maintainer: Sam Hocevar (Debian packages) <sam+deb@zoy.org>
Build-Depends: debhelper (>= 4.0), dpatch, gettext, libx11-dev, libxext-dev, libxt-dev, libxv-dev, xlibs-static-pic, libggi2-dev, libglide2-dev [i386], libesd0-dev, libaudiofile-dev, libsdl1.2-dev (>= 1.2.7-5), libasound2-dev (>= 0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi3-dev, mozilla-dev, libidl0, libglib2.0-0, libxosd-dev (>= 2.2.4-1.3), svgalibg1-dev (>= 1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev (>= 2.4.2.6), libdvdread3-dev, libslp-dev, libflac-dev (>= 1.1.1-5), libimlib2-dev, libmatroska-dev (>= 0.7.5), libfreetype6-dev, linux-kernel-headers (>= 2.5.999-test7-bk-7), libcaca-dev (>= 0.9), liblivemedia-dev (>= 2004.11.11a-1), libmpeg2-4-dev, zlib1g-dev, libdts-dev, libfribidi-dev, libcdio-dev, libxml2-dev, libid3tag0-dev, libtheora-dev, jam, nasm, libmodplug-dev, libhal-dev, libtar-dev, libdvdnav-dev, libgnutls11-dev, libavcodec-dev (>= 0.cvs20050313-1), libavformat-dev (>= 0.cvs20050313-1), libpostproc-dev (>= 0.cvs20050313-1), libncurses5-dev
Standards-Version: 3.6.1.1
Build-Depends: debhelper (>= 4.0), dpatch, gettext, libx11-dev, libxext-dev, libxt-dev, libxv-dev, xlibs-static-pic, libggi2-dev, libglide2-dev [i386], libesd0-dev, libaudiofile-dev, libsdl1.2-dev (>= 1.2.7-5), libasound2-dev (>= 0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, libaa1-dev, libdvbpsi4-dev, mozilla-dev, libidl0, libglib2.0-0, libxosd-dev (>= 2.2.4-1.3), svgalibg1-dev (>= 1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev | libwxgtk2.6-dev, libdvdread3-dev, libflac-dev (>= 1.1.1-5), libimlib2-dev, libmatroska-dev (>= 0.7.7), libfreetype6-dev, linux-kernel-headers (>= 2.5.999-test7-bk-7), libcaca-dev (>= 0.9), liblivemedia-dev (>= 2004.11.11a-1), libmpeg2-4-dev, zlib1g-dev, libdts-dev, libfribidi-dev, libcdio-dev, libxml2-dev, libid3tag0-dev, libtheora-dev, jam, nasm, libmodplug-dev, libhal-dev, libtar-dev, libdvdnav-dev, libgnutls11-dev, libavcodec-dev (>= 0.cvs20050626-1), libavformat-dev (>= 0.cvs20050626-1), libpostproc-dev (>= 0.cvs20050626-1), libncurses5-dev, libpng12-dev, xlibmesa-gl-dev
Standards-Version: 3.6.2.1
Package: vlc
Section: graphics
......@@ -170,7 +170,7 @@ Description: aRts audio output plugin for VLC
Package: mozilla-plugin-vlc
Architecture: any
Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
Recommends: mozilla-browser
Recommends: mozilla-browser | mozilla-firefox
Description: multimedia plugin for Mozilla based on VLC
This plugin adds support for MPEG, MPEG2, DVD, DivX, Ogg/Vorbis and many
more formats to your Mozilla browser. The decoding process is done by VLC
......@@ -219,97 +219,3 @@ Description: wxWindows frontend for VLC
DivX, MOV, WMV, QuickTime, mp3, Ogg/Vorbis files, DVDs, VCDs, and multimedia
streams from various network sources.
Package: vlc-alsa
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), vlc-plugin-alsa, ${misc:Depends}
Description: ALSA audio output plugin for VLC (dummy legacy package)
The vlc-alsa package has been renamed to vlc-plugin-alsa. This is a dummy
package with the sole purpose of ensuring a smooth upgrade from vlc-alsa
to vlc-plugin-alsa.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-esd
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), vlc-plugin-esd, ${misc:Depends}
Description: Esound audio output plugin for VLC (dummy legacy package)
The vlc-esd package has been renamed to vlc-plugin-esd. This is a dummy
package with the sole purpose of ensuring a smooth upgrade from vlc-esd
to vlc-plugin-esd.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-ggi
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), vlc-plugin-ggi, ${misc:Depends}
Description: GGI video output plugin for VLC (dummy legacy package)
The vlc-ggi package has been renamed to vlc-plugin-ggi. This is a dummy
package with the sole purpose of ensuring a smooth upgrade from vlc-ggi
to vlc-plugin-ggi.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-glide
Section: oldlibs
Architecture: i386
Depends: vlc (= ${Source-Version}), vlc-plugin-glide, ${misc:Depends}
Description: Glide video output plugin for VLC (dummy legacy package)
The vlc-glide package has been renamed to vlc-plugin-glide. This is a dummy
package with the sole purpose of ensuring a smooth upgrade from vlc-glide
to vlc-plugin-glide.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-gnome
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), gnome-vlc, ${misc:Depends}
Description: GNOME frontend for VLC (dummy legacy package)
The vlc-gnome package has been renamed to gnome-vlc. This is a dummy
package with the sole purpose of ensuring a smooth upgrade from vlc-gnome
to gnome-vlc.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-gtk
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), gvlc, ${misc:Depends}
Description: GTK+ frontend for VLC (dummy legacy package)
The vlc-gtk package has been renamed to gvlc. This is a dummy package with
the sole purpose of ensuring a smooth upgrade from vlc-gtk to gvlc.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-qt
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), qvlc, ${misc:Depends}
Description: Qt frontend for VLC (dummy legacy package)
The vlc-qt package has been renamed to qvlc. This is a dummy package with
the sole purpose of ensuring a smooth upgrade from vlc-qt to qvlc.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
Package: vlc-sdl
Section: oldlibs
Architecture: any
Depends: vlc (= ${Source-Version}), vlc-plugin-sdl, ${misc:Depends}
Description: SDL video and audio output plugin for VLC (dummy legacy package)
The vlc-sdl package has been renamed to vlc-plugin-sdl. This is a dummy
package with the sole purpose of ensuring a smooth upgrade from vlc-sdl
to vlc-plugin-sdl.
.
This package is only useful to ensure clean upgrades from old Debian
releases and can be safely removed.
......@@ -221,10 +221,6 @@ install: build
#mv debian/vlc/$(VIDDIR)/gnome-vlc32x32.xpm debian/gnome-vlc/$(VIDDIR)/gnome-vlc.xpm
#mv debian/vlc/$(VIDDIR)/gnome-vlc48x48.png debian/gnome-vlc/$(PIXDIR)/gnome-vlc.png
# Package: vlc-gnome
mkdir -p debian/vlc-gnome/usr/share/doc/
ln -s vlc debian/vlc-gnome/usr/share/doc/vlc-gnome
# Package: gvlc
#mv debian/vlc/usr/bin/gvlc debian/gvlc/usr/bin/
ln -s vlc debian/gvlc/usr/share/doc/gvlc
......@@ -238,28 +234,16 @@ install: build
#mv debian/vlc/$(VIDDIR)/gvlc32x32.xpm debian/gvlc/$(VIDDIR)/gvlc.xpm
#mv debian/vlc/$(VIDDIR)/gvlc48x48.png debian/gvlc/$(PIXDIR)/gvlc.png
# Package: vlc-gtk
mkdir -p debian/vlc-gtk/usr/share/doc/
ln -s vlc debian/vlc-gtk/usr/share/doc/vlc-gtk
# Package: vlc-plugin-esd
ln -s vlc debian/vlc-plugin-esd/usr/share/doc/vlc-plugin-esd
mv debian/vlc/usr/lib/vlc/audio_output/libesd_plugin.so \
debian/vlc-plugin-esd/usr/lib/vlc/audio_output/
# Package: vlc-esd
mkdir -p debian/vlc-esd/usr/share/doc/
ln -s vlc debian/vlc-esd/usr/share/doc/vlc-esd
# Package: vlc-plugin-alsa
ln -s vlc debian/vlc-plugin-alsa/usr/share/doc/vlc-plugin-alsa
mv debian/vlc/usr/lib/vlc/audio_output/libalsa_plugin.so \
debian/vlc-plugin-alsa/usr/lib/vlc/audio_output/
# Package: vlc-alsa
mkdir -p debian/vlc-alsa/usr/share/doc/
ln -s vlc debian/vlc-alsa/usr/share/doc/vlc-alsa
# Package: vlc-plugin-sdl
ln -s vlc debian/vlc-plugin-sdl/usr/share/doc/vlc-plugin-sdl
mv debian/vlc/usr/lib/vlc/audio_output/libaout_sdl_plugin.so \
......@@ -267,28 +251,16 @@ install: build
mv debian/vlc/usr/lib/vlc/video_output/libvout_sdl_plugin.so \
debian/vlc-plugin-sdl/usr/lib/vlc/video_output/
# Package: vlc-sdl
mkdir -p debian/vlc-sdl/usr/share/doc/
ln -s vlc debian/vlc-sdl/usr/share/doc/vlc-sdl
# Package: vlc-plugin-ggi
ln -s vlc debian/vlc-plugin-ggi/usr/share/doc/vlc-plugin-ggi
mv debian/vlc/usr/lib/vlc/video_output/libggi_plugin.so \
debian/vlc-plugin-ggi/usr/lib/vlc/video_output/
# Package: vlc-ggi
mkdir -p debian/vlc-ggi/usr/share/doc/
ln -s vlc debian/vlc-ggi/usr/share/doc/vlc-ggi
# Package: vlc-plugin-glide
ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
ln -s vlc debian/vlc-plugin-glide/usr/share/doc/vlc-plugin-glide
mv debian/vlc/usr/lib/vlc/video_output/libglide_plugin.so \
debian/vlc-plugin-glide/usr/lib/vlc/video_output/
# Package: vlc-glide
mkdir -p debian/vlc-glide/usr/share/doc/
ln -s vlc debian/vlc-glide/usr/share/doc/vlc-glide
endif
# Package: qvlc
......@@ -300,10 +272,6 @@ endif
#mv debian/vlc/$(VIDDIR)/qvlc32x32.xpm debian/qvlc/$(VIDDIR)/qvlc.xpm
#mv debian/vlc/$(VIDDIR)/qvlc48x48.png debian/qvlc/$(PIXDIR)/qvlc.png
# Package: vlc-qt
mkdir -p debian/vlc-qt/usr/share/doc/
ln -s vlc debian/vlc-qt/usr/share/doc/vlc-qt
# Package: vlc-plugin-arts
ln -s vlc debian/vlc-plugin-arts/usr/share/doc/vlc-plugin-arts
mv debian/vlc/usr/lib/vlc/audio_output/libarts_plugin.so \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment