Commit 23c05760 authored by Jean-Paul Saman's avatar Jean-Paul Saman
Browse files

Fix generation of libswscale.pc in ffmpeg.

parent fb04f249
......@@ -1090,7 +1090,7 @@ ifdef HAVE_UCLIBC
patch -p0 < Patches/ffmpeg-svn-internal-define.patch
patch -p0 < Patches/ffmpeg-svn-libavformat.patch
endif
patch -p0 < Patches/ffmpeg-svn-configure.patch
else
ffmpeg-$(FFMPEG_VERSION).tar.gz:
echo "ffmpeg snapshot is too old, you MUST use subversion !"
......
Index: configure
===================================================================
--- configure (revision 12501)
+++ configure (working copy)
@@ -2201,8 +2201,8 @@
fi
if enabled swscale; then
- pkgconfig_generate libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" -lswscale "libavutil = $LIBAVUTIL_VERSION"
- pkgconfig_generate_uninstalled libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "" "libavutil = $LIBAVUTIL_VERSION"
+ pkgconfig_generate libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "-lswscale -lm" "libavutil = $LIBAVUTIL_VERSION"
+ pkgconfig_generate_uninstalled libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "-lm" "libavutil = $LIBAVUTIL_VERSION"
else
pkgconfig_generate libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "" "$pkg_requires libavcodec = $LIBAVCODEC_VERSION"
pkgconfig_generate_uninstalled libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "" "$pkg_requires libavcodec = $LIBAVCODEC_VERSION"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment