Commit 1589b92e authored by Rafaël Carré's avatar Rafaël Carré

Fix check for img_resample and sws_getContext

parent e9b987f4
...@@ -3023,12 +3023,13 @@ dnl Trying with pkg-config ...@@ -3023,12 +3023,13 @@ dnl Trying with pkg-config
[AC_CHECK_HEADERS([ffmpeg/swscale.h libswscale/swscale.h])], [AC_CHECK_HEADERS([ffmpeg/swscale.h libswscale/swscale.h])],
[AC_CHECK_LIB(avcodec,img_resample,[], [AC_CHECK_LIB(avcodec,img_resample,[],
[AC_MSG_ERROR([Your FFmpeg library doesn't have the needed img_resample() function. You should rebuild it with software scaler disabled, or install the swscale headers.])], [AC_MSG_ERROR([Your FFmpeg library doesn't have the needed img_resample() function. You should rebuild it with software scaler disabled, or install the swscale headers.])],
[${FFMPEG_LIBS}])
],
[${SWSCALE_LIBS}]) [${SWSCALE_LIBS}])
])
VLC_RESTORE_FLAGS VLC_RESTORE_FLAGS
],[AC_CHECK_LIB(avcodec,img_resample,[], ],[AC_CHECK_LIB(avcodec,img_resample,[],
[AC_MSG_ERROR([Your FFmpeg library doesn't have the needed img_resample() function. You should rebuild it with software scaler disabled, or install the swscale headers.])], [AC_MSG_ERROR([Your FFmpeg library doesn't have the needed img_resample() function. You should rebuild it with software scaler disabled, or install the swscale headers.])],
[${SWSCALE_LIBS}]) [${FFMPEG_LIBS}])
] ]
) )
...@@ -3074,7 +3075,8 @@ dnl Trying with pkg-config ...@@ -3074,7 +3075,8 @@ dnl Trying with pkg-config
[-lavcodec $LDAVUTIL]) [-lavcodec $LDAVUTIL])
LDFLAGS="${LDFLAGS_save}" LDFLAGS="${LDFLAGS_save}"
CPPFLAGS="${CPPFLAGS_save}" CPPFLAGS="${CPPFLAGS_save}"
]) ],
[${SWSCALE_LIBS}])
]) ])
fi fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment