Commit 14f7e26d authored by Sam Hocevar's avatar Sam Hocevar

* debian/control:

    + Build-depend on libdvbpsi3-dev, so that we can get rid of the previous
      versions of this library.
    + Recommend the videolan-doc package.
    + Build-conflict on libavcodec-dev, just in case it enters Sid at an
      unappropriate moment.
  * debian/README.Debian:
    + Removed mention of the libmpeg2 tree, which we no longer provide.
parent 8600577e
......@@ -7,11 +7,11 @@ Notes for anyone wanting to build Debian packages of VLC.
- To build for a Debian woody system, first build a tarball using
"make dist-woody".
- Usually VLC will come with a copy of ffmpeg, faad2 and libmpeg2 in the
- Usually VLC will come with a copy of ffmpeg and faad2 in the
extras/ directory, because they are not yet available in Debian.
- If there is no CVS directory in the root, debian/rules will assume a
full build is requested and will clean ffmpeg, faad2 and libmpeg2.
full build is requested and will clean ffmpeg and faad2.
- VLC does not link with libdvdcss by default, thus it will not depend
on the libdvdcss packages. However it will use libdvdread that can
......
vlc (0.7.2.final-5) unstable; urgency=low
* debian/control:
+ Build-depend on libdvbpsi3-dev, so that we can get rid of the previous
versions of this library.
+ Recommend the videolan-doc package.
+ Build-conflict on libavcodec-dev, just in case it enters Sid at an
unappropriate moment.
* debian/README.Debian:
+ Removed mention of the libmpeg2 tree, which we no longer provide.
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Tue, 20 Jul 2004 11:25:17 +0200
vlc (0.7.2.final-4) unstable; urgency=low
* debian/rules:
......
......@@ -2,14 +2,15 @@ Source: vlc
Section: graphics
Priority: optional
Maintainer: Sam Hocevar (Debian packages) <sam+deb@zoy.org>
Build-Depends: debhelper (>= 4.0), gettext, libx11-dev, libxext-dev, libxt-dev, libxv-dev, xlibs-static-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libaudiofile-dev, libsdl1.2-dev (>= 1.2.7-5), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>= 0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi2-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, libxosd-dev (>= 2.2.4-1.3), svgalibg1-dev (>= 1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev (>= 2.4.2.4), libdvdplay0-dev (>= 1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>= 1.1.0), libimlib2-dev, libmatroska-dev (>= 0.7.0), libfreetype6-dev, libspeex-dev, linux-kernel-headers (>= 2.5.999-test7-bk-7), libcaca-dev (>= 0.9), liblivemedia-dev (>= 2004.04.23-1), libmpeg2-4-dev, zlib1g-dev, libdts-dev, libfribidi-dev, libcdio-dev, libmodplug-dev, libxml2-dev, libid3tag0-dev, libtheora-dev
Build-Depends: debhelper (>= 4.0), gettext, libx11-dev, libxext-dev, libxt-dev, libxv-dev, xlibs-static-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libaudiofile-dev, libsdl1.2-dev (>= 1.2.7-5), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>= 0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi3-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, libxosd-dev (>= 2.2.4-1.3), svgalibg1-dev (>= 1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev (>= 2.4.2.4), libdvdplay0-dev (>= 1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>= 1.1.0), libimlib2-dev, libmatroska-dev (>= 0.7.0), libfreetype6-dev, libspeex-dev, linux-kernel-headers (>= 2.5.999-test7-bk-7), libcaca-dev (>= 0.9), liblivemedia-dev (>= 2004.04.23-1), libmpeg2-4-dev, zlib1g-dev, libdts-dev, libfribidi-dev, libcdio-dev, libmodplug-dev, libxml2-dev, libid3tag0-dev, libtheora-dev
Build-Conflicts: libavcodec-dev
Standards-Version: 3.6.1.1
Package: vlc
Section: graphics
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, wxvlc, ttf-freefont
Recommends: ttf-thryomanes
Recommends: ttf-thryomanes, videolan-doc
Replaces: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
Conflicts: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
Provides: mp3-decoder
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment