Commit 028e42b2 authored by Jean-Baptiste Kempf's avatar Jean-Baptiste Kempf
Browse files

Contribs: fix sparkle compatibility for OSX 5


Signed-off-by: Jean-Baptiste Kempf's avatarJean-Baptiste Kempf <jb@videolan.org>
parent 51b80d6f
......@@ -16,9 +16,8 @@ sparkle: sparkle-$(SPARKLE_VERSION).zip .sum-sparkle
$(RM) -R $@ && mkdir -p $@ && cd $@ && unzip ../$<
cd $@/Extras/Source\ Code/Configurations && \
sed -i.orig -e s/"GCC_TREAT_WARNINGS_AS_ERRORS = YES"/"GCC_TREAT_WARNINGS_AS_ERRORS = NO"/g \
-e s/"ARCHS = .*"/"ARCHS = $(ARCH)"/ \
ConfigCommonRelease.xcconfig && \
sed -i.orig -e s/10\.4/$(OSX_VERSION)/g -e s/10\.5/$(OSX_VERSION)/g ConfigCommon.xcconfig
-e s/"ARCHS = .*"/"ARCHS = $(ARCH)"/ ConfigCommonRelease.xcconfig && \
sed -i.orig -e s/MacOSX10.5.sdk/MacOSX$(OSX_VERSION).sdk/g ConfigCommon.xcconfig
touch $@
.sparkle: sparkle
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment