Commit 6ee40f0a authored by Filip Roséen's avatar Filip Roséen Committed by Thomas Guillem

compile-libvlc.sh: fix NDK version check

The diagnostic certainly implies that the shell script shall abort if
the version of the NDK is less than 11, though the previous case-check
only matched versions matching "11*".

This commit changes the implementation so that we check whether "$REL"
is greater-than-or-equal compared to 11.
Signed-off-by: Thomas Guillem's avatarThomas Guillem <thomas@gllm.fr>
parent 4680726b
......@@ -281,19 +281,17 @@ fi
# try to detect NDK version
GCCVER=4.9
REL=$(grep -o '^Pkg.Revision.*[0-9]*.*' $ANDROID_NDK/source.properties |cut -d " " -f 3 | cut -d "." -f 1)
case "$REL" in
11*)
if [ "${HAVE_64}" = 1 ];then
ANDROID_API=android-21
else
ANDROID_API=android-9
fi
;;
*)
if [ "$REL" -ge 11 ]; then
if [ "${HAVE_64}" = 1 ];then
ANDROID_API=android-21
else
ANDROID_API=android-9
fi
else
echo "You need the NDKv11 or later"
exit 1
;;
esac
fi
SYSROOT=$ANDROID_NDK/platforms/$ANDROID_API/arch-$PLATFORM_SHORT_ARCH
SRC_DIR=$PWD
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment