Commit 2ccd4e6b authored by Alexandre Janniaux's avatar Alexandre Janniaux Committed by Felix Paul Kühne
Browse files

src: remove libtool version for iOS/tvOS

The libtool versionning is there to handle linkage compatibility during
runtime with older/more recent version of the libraries. On iOS and
tvOS, the dynamic libraries MUST be shipped in a framework. A framework
already provides its own way of handling versionning, and applications
cannot install global dynamic libraries (except maybe on jailbroken
devices) so cannot really use the libtool versionning features for
anything.
parent eab777c5
......@@ -552,6 +552,15 @@ libvlccore_la_LIBADD += libvlccore_objc.la
libvlccore_la_LDFLAGS += -Wl,-framework,Foundation -Xlinker -install_name -Xlinker @rpath/libvlccore.dylib -Wl,-U,_vlc_static_modules
endif
# iOS and tvOS applications cannot install global shared libraries and
# dylibs must be in frameworks so there's no need for libtool versionning.
if HAVE_IOS
libvlccore_la_LDFLAGS += -avoid-version
endif
if HAVE_TVOS
libvlccore_la_LDFLAGS += -avoid-version
endif
libvlc_win32_rc.$(OBJEXT): libvlc_win32_rc.rc $(top_srcdir)/extras/package/win32/libvlc.dll.manifest
$(WINDRES) --include-dir $(top_srcdir)/share --include-dir $(top_srcdir)/extras/package/win32 -i $< -o $@
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment