Commit b25546fc authored by m1s4k1's avatar m1s4k1

Update deps

parent a78c9264
Pipeline #22559 passed with stage
in 2 minutes and 28 seconds
apply plugin: 'com.android.application'
apply plugin: 'kotlin-android'
apply plugin: 'kotlin-android-extensions'
apply plugin: 'kotlin-kapt'
android {
packagingOptions {
exclude 'META-INF/main.kotlin_module'
......
......@@ -49,7 +49,6 @@ android {
dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
implementation 'androidx.appcompat:appcompat:1.1.0'
implementation "androidx.core:core-ktx:$rootProject.ext.androidxCoreVersion"
implementation project(':application:tools')
......
......@@ -59,7 +59,6 @@ android {
dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
// fixme When we update to 1.2.0 remember to remove the workaround in SecondaryActivity.applyOverrideConfiguration
implementation 'androidx.appcompat:appcompat:1.1.0'
......
......@@ -47,7 +47,6 @@ android {
dependencies {
implementation project(':application:tools')
implementation project(':application:vlc-android')
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
implementation "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version"
implementation "org.jetbrains.kotlinx:kotlinx-coroutines-core:$rootProject.ext.kotlinx_version"
implementation "org.jetbrains.kotlinx:kotlinx-coroutines-android:$rootProject.ext.kotlinx_version"
......
......@@ -45,7 +45,6 @@ android {
}
dependencies {
api "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
api 'androidx.multidex:multidex:2.0.1'
......
......@@ -30,7 +30,6 @@ dependencies {
implementation "androidx.preference:preference:$androidxPreferencesVersion"
api "androidx.tvprovider:tvprovider:$rootProject.ext.androidxLeanbackVersion"
implementation("com.squareup.okhttp3:logging-interceptor:4.2.1")
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
implementation "org.jetbrains.kotlinx:kotlinx-coroutines-core:$rootProject.ext.kotlinx_version"
implementation "org.jetbrains.kotlinx:kotlinx-coroutines-android:$rootProject.ext.kotlinx_version"
implementation "androidx.core:core-ktx:$rootProject.ext.androidxCoreVersion"
......
......@@ -179,7 +179,6 @@ dependencies {
api "androidx.tvprovider:tvprovider:$rootProject.ext.androidxLeanbackVersion"
// Kotlin
api "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
api "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version"
api "org.jetbrains.kotlinx:kotlinx-coroutines-core:$rootProject.ext.kotlinx_version"
api "org.jetbrains.kotlinx:kotlinx-coroutines-android:$rootProject.ext.kotlinx_version"
......
// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
ext.android_plugin_version = '4.0.1'
ext.kotlin_version = '1.3.72'
ext.kotlin_version = '1.4.10'
ext.kotlinx_version = '1.3.6'
repositories {
flatDir dirs: "gradle/plugins"
......@@ -56,7 +56,7 @@ ext {
//fixme : When we update this dep, please verify of this issue is fixed: https://github.com/material-components/material-components-android/issues/1086
// if so, revert application/vlc-android/res/values[-v21]/styles.xml -> AppModalStyle
androidxMaterialVersion = '1.1.0'
constraintLayoutVersion = '1.1.3'
constraintLayoutVersion = '2.0.1'
archVersion = '2.1.0'
roomVersion = '2.2.5'
pagingVersion = '2.1.2'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment