Commit edad4b8a authored by Sam Hocevar's avatar Sam Hocevar
Browse files

* bootstrap: Only start removing files when required tools have been

    checked, to prevent inadvertent file losses.
parent 10b303ec
#! /bin/sh
## bootstrap file for the VLC media player
## $Id: bootstrap,v 1.73 2003/10/20 10:37:56 gbazin Exp $
## $Id: bootstrap,v 1.74 2003/10/23 15:30:22 sam Exp $
##
## Authors: Sam Hocevar <sam@zoy.org>
......@@ -21,17 +21,108 @@ CYGWIN=binmode
export CYGWIN
set -e
set -x
##
## Naively assume our system doesn't suck. Unfortunately it seldom doesn't.
## Check for various tools
##
AUTOMAKESUCKS=no
INSTALLSUCKS=no
# Check for automake
amvers="none"
if automake-1.7 --version >/dev/null 2>&1; then
amvers="-1.7"
# If we also have 1.6 (>> 1.6.1), use it instead because it is faster
if automake-1.6 --version >/dev/null 2>&1; then
if expr "`automake-1.6 --version | sed -e '1s/[^0-9]*//' -e q`" ">" "1.6.1" > /dev/null 2>&1; then
amvers="-1.6"
fi
fi
elif automake-1.6 --version >/dev/null 2>&1; then
amvers="-1.6"
if expr "`automake-1.6 --version | sed -e '1s/[^0-9]*//' -e q`" "<=" "1.6.1" > /dev/null 2>&1; then
AUTOMAKESUCKS=yes
fi
elif automake-1.5 --version >/dev/null 2>&1; then
INSTALLSUCKS=yes
amvers="-1.5"
elif automake --version > /dev/null 2>&1; then
amvers=""
case "`automake --version | sed -e '1s/[^0-9]*//' -e q`" in
0|0.*|1|1.[01234]|1.[01234][-.]*)
amvers="none" ;;
1.5|1.5.*)
INSTALLSUCKS=yes ;;
1.6|1.6.0|1.6.1)
AUTOMAKESUCKS=yes ;;
esac
fi
if test "${amvers}" = "none"; then
set +x
echo "you need automake version 1.5 or later"
exit 1
fi
# Check for gettext
if gettextize --version >/dev/null 2>&1; then
# Autopoint is available from 0.11.3, but we need 0.11.5
if expr `gettextize --version | sed -e '1s/[^0-9]*//' -e q` \
'>=' 0.11.5 >/dev/null 2>&1; then
# We have gettext, and a recent version! Everything is cool.
autopoint=autopoint
GETTEXT=yes
else
# User's gettext is too old. try to continue anyway.
echo > ABOUT-NLS
mkdir -p intl
echo > intl/Makefile.am
cat >> m4/private.m4 << EOF
dnl User's gettext is too old, so this is a no-op
AC_DEFUN([AM_GNU_GETTEXT_VERSION], [])
EOF
autopoint=:
GETTEXT=old
fi;else
# we don't have gettext. grmbl. try to continue anyway.
echo > ABOUT-NLS
mkdir -p intl
echo > intl/Makefile.am
cat >> m4/private.m4 << EOF
dnl User does not have gettext, so this is a no-op
AC_DEFUN([AM_GNU_GETTEXT_VERSION], [])
EOF
autopoint=:
GETTEXT=no
fi
# Check for pkg-config
if pkg-config --version >/dev/null 2>&1; then
# We have pkg-config, everything is cool.
PKGCONFIG=yes
else
# Not present, use a workaround.
cat >> m4/private.m4 << EOF
dnl User does not have pkg-config, so this is a no-op
AC_DEFUN([PKG_CHECK_MODULES], [:])
EOF
PKGCONFIG=no
fi
aclocal=aclocal${amvers}
automake=automake${amvers}
autoconf=autoconf
autoheader=autoheader
##
## Generate the modules makefile, by parsing modules/**/Modules.am
##
set +x
printf "generating modules/**/Makefile.am and m4/private.m4"
# Prepare m4/private.m4
......@@ -276,95 +367,6 @@ rm -f m4/oldgettext.m4 stamp-pic configure.ac.in Modules.am
# remove new vlc cruft
rm -f stamp-builtin stamp-h* mozilla/stamp-pic
# Check for gettext
if gettextize --version >/dev/null 2>&1; then
# Autopoint is available from 0.11.3, but we need 0.11.5
if expr `gettextize --version | sed -e '1s/[^0-9]*//' -e q` \
'>=' 0.11.5 >/dev/null 2>&1; then
# We have gettext, and a recent version! Everything is cool.
autopoint=autopoint
GETTEXT=yes
else
# User's gettext is too old. try to continue anyway.
echo > ABOUT-NLS
mkdir -p intl
echo > intl/Makefile.am
cat >> m4/private.m4 << EOF
dnl User's gettext is too old, so this is a no-op
AC_DEFUN([AM_GNU_GETTEXT_VERSION], [])
EOF
autopoint=:
GETTEXT=old
fi;else
# we don't have gettext. grmbl. try to continue anyway.
echo > ABOUT-NLS
mkdir -p intl
echo > intl/Makefile.am
cat >> m4/private.m4 << EOF
dnl User does not have gettext, so this is a no-op
AC_DEFUN([AM_GNU_GETTEXT_VERSION], [])
EOF
autopoint=:
GETTEXT=no
fi
# Check for pkg-config
if pkg-config --version >/dev/null 2>&1; then
# We have pkg-config, everything is cool.
PKGCONFIG=yes
else
# Not present, use a workaround.
cat >> m4/private.m4 << EOF
dnl User does not have pkg-config, so this is a no-op
AC_DEFUN([PKG_CHECK_MODULES], [:])
EOF
PKGCONFIG=no
fi
# Check for automake
amvers="none"
if automake-1.7 --version >/dev/null 2>&1; then
amvers="-1.7"
# If we also have 1.6, use it instead because it is faster
if automake-1.6 --version >/dev/null 2>&1; then
if expr "`automake-1.6 --version | sed -e '1s/[^0-9]*//' -e q`" ">" "1.6.1" > /dev/null 2>&1; then
amvers="-1.6"
fi
fi
elif automake-1.6 --version >/dev/null 2>&1; then
amvers="-1.6"
if expr "`automake-1.6 --version | sed -e '1s/[^0-9]*//' -e q`" "<=" "1.6.1" > /dev/null 2>&1; then
AUTOMAKESUCKS=yes
fi
elif automake-1.5 --version >/dev/null 2>&1; then
INSTALLSUCKS=yes
amvers="-1.5"
elif automake --version > /dev/null 2>&1; then
amvers=""
case "`automake --version | sed -e '1s/[^0-9]*//' -e q`" in
0|0.*|1|1.[01234]|1.[01234][-.]*)
amvers="none" ;;
1.5|1.5.*)
INSTALLSUCKS=yes ;;
1.6|1.6.0|1.6.1)
AUTOMAKESUCKS=yes ;;
esac
fi
if test "${amvers}" = "none"; then
set +x
echo "you need automake version 1.5 or later"
exit 1
fi
aclocal=aclocal${amvers}
automake=automake${amvers}
autoconf=autoconf
autoheader=autoheader
# Automake complains if this is not present
rm -f vlc-config.in && printf "" > vlc-config.in
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment