Commit cbd0c5c4 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

PulseAudio: support versions 0.9.16-0.9.21 with the Xlib hack

parent bbab5a93
......@@ -3528,8 +3528,20 @@ AS_IF([test "${enable_pulse}" != "no"], [
PKG_CHECK_MODULES([PULSE], [libpulse >= 0.9.22], [
have_pulse="yes"
], [
AS_IF([test "x${enable_pulse}" != "x"], [
AC_MSG_ERROR([$PULSE_PKG_ERRORS. PulseAudio 0.9.22 or later required.])
PKG_CHECK_MODULES([PULSE], [libpulse >= 0.9.16], [
AS_IF([test "${no_x}" != "yes"], [
have_pulse="yes"
PULSE_LIBS="$PULSE_LIBS ${X_LIBS} ${X_PRE_LIBS} -lX11"
], [
AS_IF([test "${enable_pulse}" = "yes"], [
AC_MSG_ERROR([Xlib is required with PulseAudio pre-0.9.22 versions
(see http://www.pulseaudio.org/ticket/799 for further reference).])
])
])
], [
AS_IF([test "x${enable_pulse}" != "x"], [
AC_MSG_ERROR([$PULSE_PKG_ERRORS. PulseAudio 0.9.22 or later required.])
])
])
])
])
......
......@@ -32,6 +32,9 @@
#include <pulse/pulseaudio.h>
#include <vlc_pulse.h>
#if !PA_CHECK_VERSION(0,9,22)
# include <vlc_xlib.h>
#endif
static int Open ( vlc_object_t * );
static void Close ( vlc_object_t * );
......@@ -597,6 +600,11 @@ static int StreamMove(vlc_object_t *obj, const char *varname, vlc_value_t old,
*/
static int Open(vlc_object_t *obj)
{
#if !PA_CHECK_VERSION(0,9,22)
if (!vlc_xlib_init(obj))
return VLC_EGENERIC;
#endif
audio_output_t *aout = (audio_output_t *)obj;
pa_operation *op;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment