Commit c95734c9 authored by Ron Wright's avatar Ron Wright Committed by Jean-Baptiste Kempf

bluray: Fix BD_EVENT_UO_MASK_CHANGED case

Building VLC with a libbluray version older than 0.8.1 results in a build
failure because the BD_EVENT_UO_MASK_CHANGED enum does not exist in those
older versions. This problem manifests itself in Ubuntu 14.04.

  CC       access/liblibbluray_plugin_la-bluray.lo
access/bluray.c: In function ‘blurayHandleEvent’:
access/bluray.c:1985:10: error: ‘BD_EVENT_UO_MASK_CHANGED’ undeclared (first use in this function)
     case BD_EVENT_UO_MASK_CHANGED:
          ^
access/bluray.c:1985:10: note: each undeclared identifier is reported only once for each function it appears in
make[4]: *** [access/liblibbluray_plugin_la-bluray.lo] Error 1
Signed-off-by: Jean-Baptiste Kempf's avatarJean-Baptiste Kempf <jb@videolan.org>
parent e02e73ca
......@@ -1982,9 +1982,11 @@ static void blurayHandleEvent(demux_t *p_demux, const BD_EVENT *e)
case BD_EVENT_PLAYMARK:
case BD_EVENT_ANGLE:
break;
#if BLURAY_VERSION >= BLURAY_VERSION_CODE(0,8,1)
case BD_EVENT_UO_MASK_CHANGED:
/* This event could be used to grey out unselectable items in title menu */
break;
#endif
case BD_EVENT_MENU:
p_sys->b_menu_open = e->param;
break;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment